How to recalculate G/L account balances
Description

Cause

At times, the Period Posting History table may become damaged, causing an out-of-balance condition on the General Ledger Detail Report or the General Ledger Trial Balance.

Resolution

Notes:

  • Use caution when recalculating account balances. Always make a backup first. If necessary, seek the assistance of a qualified Sage Software business partner or Sage Software Customer Support analyst.
  • All users must log out of the company to ensure that no transactions post to General Ledger during the recalculation.
  • These procedures overwrite any changes made to account balances in Data File Display and Maintenance (DFDM).
  1. Reinitialize The GL_PeriodPostingHistory.m4t
  2. Click General Ledger, Utilities, Recalculate Account Balances.
  3. Click Proceed.
  • Recalculate Account Balances is used to recalculate and realign account balances based on transaction data. It processes every transaction in every account for all fiscal years.
  • Use Recalculate Account Balances for all fiscal years and to validate the period beginning balance for all accounts.


DocLink: How to erase or manually recreate data files using the Reinitialize Data Files utility
DocLink: Beginning balances do not match the ending balances from the prior period in General Ledger

Steps to duplicate
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