Reports/inquiries are missing on the menu and/or in Security Administration
Description

Reports appear in Reports Manager but are missing from the report menu. This occurs for some users. The reports may also be missing from Security Administration, which stops you from granting access.

Cause

Possible causes

  • Report was adding using the Information Assistant (IA) application
  • Sage Desktop needs to be reopened
  • The report is a duplicate report with the same name and menu group in Reports Manager
  • You rearranged the reports in Reports Manager and they're no longer in the default report menu order
  • Corrupt master.qxm (security file) in the Global folder
Resolution

Make a backup of your Sage 300 CRE files before attempting any of the solutions below.

 

Information Assistant

If you added the report using the Information Assistant (IA) application, the report only shows for Administrators and the user that added the report. Remove the report from Report Manager and add it back through the appropriate module.

Refresh files

Close and re-open the Sage Desktop to refresh Security Administration.

If the still doesn't show, run the Configuration Hub on the server with all users logged out 

Fix report names

Change the report name

  1. Delete the report from the Report Manager for the appropriate module.
  2. Add it back with a slightly different name.
  3. Run the Configuration Hub.

Fix duplicate report names

There are duplicate reports in the application Reports, Report Manager with exactly the same Report name and Menu group.

  1. Delete the duplicate.
  2. Complete the steps in the Default menu order section below.

Default menu order

Rearrange the reports so they are in the default report menu order. Custom menu groups should come after all the default menus, followed by any reports that aren't assigned to a menu group. 

  1. Open Report Manager for the appropriate application from the Tasks or Applications list of the Sage Desktop.
  2. Click Arrange.
  3. See the default Reports or Inquiry menu group order.
  4. Select the report you need to move and use the Move Up/Move Down buttons.
    • Example: The default menu order for Accounts Payable is:
      • Invoice Registers
      • Cash Management
      • Compliance
      • Lien Waivers
      • GL Reconciliation
      • Miscellaneous
      • Lists
      • Forms
      • Setup
      • Custom menu groups
      • Reports not in a menu group
  5. Repeat step 4 for any additional reports until reports are in the correct default order.
  6. Click Close when finished.
  7. Run the Configuration Hub.

Other solutions

See other possible solutions. This includes items such as verifying permissions, confirming report locations, or incorrect report migrations.

Issue with the security files

If the options above don't fix the issue, contact Sage Support to determine if the security (QXM) file is the issue.

 



[BCB:156:Chat 300 CRE US:ECB]

 

Steps to duplicate
Related Solutions

How do I set up or change security in Sage 300 Construction and Real Estate?

Why is my report or inquiry missing from the menu?