Error: "MyAssistant failed to generate an SM DSN." (DSN not on server)
Description

The full error generated during MyAssistant configuration is "Error: MyAssistant failed to generate an SM DSN for the following data folders: folder name. Some SM features may be disabled".

This may also appear as the error "Unable to save options when closing the MyAssistant Server Configuration Manager".

Cause

The SM DSN isn’t created until you launch a Service Management report.

Resolution

You have Service Management

  1. Open Service Management on the server.
  2. Select Reports, Work Orders, Work Orders in Progress.
  3. Click Close to close the preview.
  4. Exit Service Management.
  5. Relaunch Sage MyAssistant and complete the User Configuration Manager.

 

You don't have Service Management

  1. Open MyAssistant Configuration Manager on the server.
  2. Click the Sage 300 CRE Data Folder.
  3. Scroll to the right on the company giving the error to see the SM column.
  4. Highlight the SM number only and delete it. Leave the field blank.
  5. Click OK and close the configuration manager.
Steps to duplicate
Related Solutions

Error: "MyAssistant failed to generate an SM DSN" (SM DSN not on workstation)