Error: "MyAssistant failed to generate an SM DSN" (SM DSN not on workstation)
Description
Cause
The SM DSNs do not exist on the workstation that MyAssistant Designer is installed on.
Resolution
[BCB:5:Third-party support:ECB]

Option 1

  1. Open Service Management on the server.
  2. Select Reports, Work Orders, Work Orders in Progress.
  3. Click Close to close the preview.
  4. Exit Service Management.
  5. Relaunch Sage MyAssistant and proceed through the Sage MyAssistant user configuration manager.

Option 2

  1. Launch ODBC Administrator from Start, All Programs, ODBC, 32bit ODBC Administrator.
  2. Click the System DSN tab.
    Note: If the SM DSNs that exist on the server do not exist in this list, they must be added.
  3. Click Add.
  4. Select Pervasive ODBC Client Interface, click Finish.
  5. Copy and paste the Data Source Name of the SM DSN on the server to the workstation.
  6. Change Server Name/IP to the MyAssistant server name.
  7. Click Get List under Database Name.
  8. Select the SM DSN from the list.
  9. Click OK.
  10. Repeat steps for any additional missing SM DSNs.
  11. Click OK when finished.
DocLink: Error: "MyAssistant failed to generate an SM DSN." (SM DSN not on server)
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