Set Up Security option is greyed out when logged in as administrator
Description
Cause
  • Damaged files
  • User rights have been changed
Resolution

Section 1: Delete CAX and/or CAC files

  1. Have all users log out of the company.
  2. Browse to company data path. See How to find data path and program path.
  3. Sort the files by type. Find all CAX or CAC type files. The file names of each of these files are the user names. Write them down for the next step.

    Note: The user names are case sensitive

  4. Log into the company as the first user (first CAX file found in step 3) and go to Maintain, Users, and then Set Up Security. If Set Up Security is greyed out, that user does not have administrative access.
  5. Continue to log in as each subsequent user until you find the user that can access Set Up Security.
  6. Once in the security settings window, change the security settings as desired for each user. If a user shows administrative access but still finds that security options are greyed out, proceed to Section 2.

Section 2: Damaged Files

  1. Click Maintain and select Company Information. Then copy the Directory line.
  2. Press the Windows Key + R.
  3. Paste the directory line in the Run box that pops up and click OK.
  4. Highlight all CAX or CAC files, and move them out of data path to another location.
  5. Delete any files ending in DDF.
  6. Re-open the company, and log in as user with administrative rights.
  7. Verify that you can select Maintain, Users, and then Set Up Security.

Section 3: Damaged User

  1. Log in to the company as another user with Administrator access.
  2. Delete the user in question.
  3. Recreate the user with Administrator rights.
Steps to duplicate
Related Solutions