Error: "Invalid directory, using current working directory instead"
Description
Cause
  • There is an invalid file location path for Printouts
  • The user getting the message doesn't have access to that path
  • The drive is mapped incorrectly for the workstation
  • The report design Print Options specify a path that is not valid for the user running the report
Resolution
[BCB:3:Network warning:ECB]
[BCB:4:Operating system warning:ECB]
  1. Navigate to File, Company Settings, File Locations
  2. In the window that pops up, scroll down to Printouts
  3. Confirm the path for the Printouts is a valid path
  4. If it is valid path, confirm the user getting the message has access to that path
  5. If the path has a mapped drive, verify that the mapping is correct and correct as needed
  6. Enter the path as a UNC path that does not depend on the mapped drive. Note: the best recommendation is to have the path set to a UNC path
  7. If it isn't a valid path, delete the path
  8. By deleting the path, printing to file will default to the company data folder the user is working in

Note: If the File Locations is a valid path, there may be a specified path on the report design. Open the report in Report Designer and check File, Page Setup, Print Options. In Select File, specify a path that is valid for all users.

DocLink: Can journals be saved to a file automatically?
Steps to duplicate
Related Solutions