Error: "1 user limit exceeded, No valid activation found", when launching Sage 100 Advanced or Premium through Remote Desktop Services (Terminal Server) or Citrix from more than one workstation
Description

Cause
  • When Workstation Setup is installed on the Terminal Server for multiple users, the activation/licensing needs to be set up for multiple users as well
  • Windows firewall on the Sage 100 application server may cause this error in a multi terminal server environment
Resolution
[BCB:1:Backup warning:ECB]

Copy the "Activate.pvx" from the "..\MAS90\Home\Lib\Keys" directory where Sage 100 is installed, to the "..\MAS90\Home\Lib\Keys" directory where the Workstation Setup client has been installed on the Terminal Server. See the detailed steps below:

1. On the Application Server:

  1. Stop the Sage 100 Advanced or Premium (formerly Sage MAS 200 or MAS 200 SQL) Service or Application
  2. Verify that there are no 'Pvxwin32.exe' processes running in Task Manager
  3. Via Windows (File) Explorer, browse to the "..\MAS90\Home\Lib\Keys\" directory where Sage 100 ERP is installed
  4. Copy the 'Activate.pvx' file located here
    • Note: Right-click the file, select Copy

2. On the RDS\Terminal Server:

  1. Right-click the short-cut icon used to launch or access Sage 100 (formerly Sage MAS 200)
  2. Select Properties
  3. Click the Open File Location button to access the "..\MAS90\Home" directory where Sage 100 Workstation Setup client is installed
  4. Open the "Lib" folder in "..\MAS90\Home"
  5. Open the "Keys" folder in "..\MAS90\Home\Lib"
  6. Rename the 'Activate.pvx' file located here
    • Note: Right-click the file, select Rename, and give the file a different name
  7. Paste the 'Activate.pvx' file copied from the Application Server into the "..\MAS90\Home\Lib\Keys" folder.
    • Note: Right-click in a blank area in the folder, then select Paste to past the copied file.

3. Back on the Application Server:

  1. Restart the Sage 100 Advanced or Premium (formerly Sage MAS 200 or MAS 200 SQL) Service or Application

4. Back on the RDS\Terminal Server:

  1. Verify that multiple users can log into Sage 100 from the RDS\Terminal Server

Multi Terminal Server environment: review Windows Firewall settings if still receiving "1 user limit exceeded" (not "xx user limit exceeded") in an environment with multiple terminal servers as workstations for Sage 100.


DocLink: How to configure Windows Firewall for Sage 100 Advanced and Premium (video)
DocLink: How to install Workstation Setup for Sage 100
DocLink: What virtual platforms or virtualized operating systems and environments are supported for Sage 100?

[BCB:155:Chat 100 US:ECB]


Defect ID
Steps to duplicate
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