Error: "GL period closed. Entry not allowed."
Description

Cause
  • The General Ledger period is closed
  • The accounting date of the entry is beyond the farthest General Ledger future date
Resolution

Choose an option below based on how you want to handle the entries. These steps apply to entries posted in the current or prior fiscal year.

Open the period and post

  1. From the General Ledger Tasks menu, select Open/Close Posting period.
  2. Select the correct company if applicable.
  3. Clear the checkbox for the date period used and click OK.
  4. Complete posting the entries.
  5. Recheck the box from step 3.

Allow entries for a closed period

  1. Launch the Sage Desktop.
  2. Go to General Ledger, GL Settings.
  3. Select Processing Options.
  4. Check Allow Entry to Close Period, click OK, and OK.
  5. Complete posting the entries.
  6. Follow steps 1-3 to turn Allow Entries to Closed Period off.

Entries more than one year in the future

You can't post more than one year into the future. You'll need to close the period or year until you can post the transactions. Only follow this process if you actually need to close your ledger. If the date on the transaction is incorrect, contact Sage Support for alternate fixes.

Entries before the prior fiscal year

Work with your Sage Consultant or Sage Expert Services for entries with an accounting date more than one year in the past. See more information about entries for two or more years ago.

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Steps to duplicate
Related Solutions

How does the "Allow entry to closed period" setting in General Ledger (GL) work?