Error: "Application does not match country currently selected" after installing Windows updates (Country registry key)
Description
Cause

If a Windows machine's regional settings are English (Canada), Microsoft Windows update changes the country code in the registry to a "1" instead of a "2", conflicting with what Sage 300 Construction and Real Estate is expecting for that code.

Resolution
[BCB:4:Operating system warning:ECB]

OPTION I

  1. Close out of Sage 300 Construction and Real Estate applications.
  2. From the Windows Start menu, select Run or in the search box enter Run and select Run.
  3. In the Open box, enter REGEDIT and click OK.
  4. Open the registry and change the value of HKEY_Current_User\Control Panel\ International\iCountry to a "2"
  5. If this does not work, try Option II

Option II

  1. Repeat first 3 steps in Option I.
  2. Open the registry and change the value of HKEY_USERS\.DEFAULT\Control Panel\International\iCountry to a '2' and HKEY_USERS\.DEFAULT\Control Panel\International\sCountry to 'Canada'.
  3. Repeat above for each registry key underneath the HKEY_USERS key(S-1-5-18,S-1-5-19,S-1-5-20,S-1-5-21-2070541261-389910272-1345520227-169679)
  4. Log out of AP and test again.

If these steps do not get rid of the message or if the iCountry value is already "2", refer to the article below in Related Resources.

DocLink: Error: "Application does not match country currently selected"
Defect ID
537226
Steps to duplicate
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