Error: "Corrupt data. Error accessing the file. The file may be corrupt."
Description
Cause
  • Pervasive/Actian PSQL issues
  • Corrupt Global folder
Resolution
[BCB:5:Third-party support:ECB]

Option I:

If this error occurs on only one workstation, the Pervasive service may need to be restarted on that workstation. Refer to the article in Related resources below for instructions.

Option II:

If the error occurs on all workstations and the server and restarting Pervasive services does not resolve the issue, it may indicate that your Global folder is corrupted. Restore your Global folder from backup. The Global folder is located under C:\ProgramData\Sage\Timberline Office\9.5\Accounting or C:\Documents and Settings\All Users\Application Data\Sage\Timberline Office\9.5\Accounting.

  1. Have all users exit out of Sage 300 CRE.
  2. Locate a recent backup of the Global folder.
  3. Restore this backup to the server's desktop. (Do not over-write the existing Global folder.)
  4. Locate the existing Global in either C:\ProgramData\Sage\Timberline Office\9.5\Accounting or C:\Documents and Settings\All Users\Application Data\Sage\Timberline Office\9.5\Accounting.
  5. Rename the Global folder to Global-old.
  6. Copy and paste the Global folder that you restored to your desktop
  7. Run Configuration Hub

Note: If you do not have a backup, please contact Support to obtain a blank Global folder. Using a blank Global folder will require Security in Sage 300 CRE to be setup again.

DocLink: How do I restart Pervasive/Actian and Sage services to unlock files?
DocLink: INTERNAL: Tracking cases where Sage 300 CRE Security has to be rebuilt
Defect ID
Steps to duplicate
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