How do I restart Pervasive/Actian/Zen and Sage services to unlock files?
Description
Cause

Files locked open by Pervasive/Actian due to computer crash, power loss, and/or abandoned terminal services sessions, etc.

Resolution

Warning: Don’t restart Pervasive/Actian services while operators are using a Sage 300 Construction and Real Estate or Sage Estimating application. If you do, they will lose their network connection to the Pervasive/Actian engine. This causes data corruption.
Notes:

 

  1. To restart the Pervasive/Actian/Zen and Sage services (on server or terminal server):
    1. At the server, log on as the administrator.
    2. Start and click Start Search.
    3. Type services.msc. Click OK.
    4. Locate the services:
      • Versions 24.1 and earlier: Pervasive/Actian PSQL Relational Engine and Pervasive/Actian PSQL Transactional Engine
      • Versions 24.2 and later: Actian Zen Enterprise Server
      • All versions: Sage Service Host services
      • Note: On a terminal server or workstation there may only be one Pervasive/Actian PSQL Workgroup service
    5. Right-click the service(s) and select Stop.
    6. Right-click the service(s) again and select Start.
  2. To restart Pervasive/Actian Engine on a workstation that does not have the Pervasive/Actian service installed:
    Note: By default, versions 24.2 and later install on the workstation as an application and will not have services.
    1. Click Start, All Programs, Pervasive PSQL, Engines, Stop Engine.
    2. Click Start, All Programs, Pervasive PSQL, Engines, Start Engine.
    3. Start and click Start Search.
    4. Type services.msc. Click OK.
    5. Locate Sage Service Host, right click. Select Restart.
  3. If you are still receiving errors relating to locked files, you may need to reboot the server and any workstations or terminal servers involved.


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