Error: "The checks must be printed before you can print and update the Check and Electronic Payment Register"
Description
Cause
The system does not consider all of the check entries currently in Accounts Payable check data entry files to have been printed.
Resolution
[BCB:1:Backup warning:ECB]

    Note: This error occurs because the system does not consider all of the check entries currently in Accounts Payable check data entry files to have been printed. The goal is to make sure all check entries have printed, and to ensure that records that the system checks indicate they have been printed.

    Possible Resolution 1:  Verify that there are no unprinted Manual Checks

    1. Open Accounts Payable, Main menu, Manual Check and Payment Entry
    2. Select Batch, if applicable
    3. Select Bank Code
    4. Click Magnifying Glass at Check Number field
    5. Checks listed with check number, *PRNT* need to be printed
    6. If there are no *PRNT* records in the selected bank code, select another bank code until all have been verified

    Posslble Resolution 2: Check if all checks have been printed by testing if the system will still print checks if Print Checks Already Printed option is left unselected (unchecked)

    1. Open Accounts Payable, Check Printing and Electronic Payment menu, Check Printing and Electronic Payment
    2. Verify the Bank Code, Form Code, Check Type, etc.
    3. Leave the Print Checks Already Printed option unselected
    4. Print checks to plain paper and verify that no checks printed
    5. If any check has printed, then consider returning to Check Printing and Electronic Payment to re-print checks to appropriate paper.

    Possible Resolution 3: If checks have already been correctly printed multiple times, even to plain paper, but the system still gives the error message.

    1. Open Library Master, Utilities, Data File Display and Maintenance
    2. Click on the Ok button at the Warning Message
    3. Enter File Name: AP_CheckHeader.M4T and ENTER key
    4. The first Check record will display on the main window, select the Edit button.
    5. At the Field Number click and select CheckPrinted$
    6. Make sure the Old Data field shows Y
    7. If Old Data field shows "N" the Change to "Y"
    8. Follow the same steps for all remaining records
    DocLink: Error: "Bank code in use by another task", "Check Printing in Process" or "Other Check Printing in Progress"
    DocLink: How to print Accounts Payable checks in Sage 100
    Defect ID
    Steps to duplicate
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