Error: "Failed to retrieve data from the database" (PJ Purchase order forms)
Description
Cause

In Project Management, when you enter a purchase order, you can change the description of the lower items in the header of the purchase order by clicking in a field and clicking Change Desc. The Crystal purchase order forms on the Reports menu do not work with the new descriptions unless you modify the reports. This does not affect subcontracts.

NOTE:  This error can also occur if the PJ Settings, Change Management report is not mapped correctly (mapped to an old server after a migration) or has a non-task report selected instead of a task report. If the descriptions on the commitment header match the canned/default descriptions, check PJ settings and verify that a task based report is selected and that the report exists in the mapped location.

Resolution

Option 1 - If you own Crystal Reports, modify the report to use the new descriptions:

  1. Open the report in Crystal Reports.
  2. From the Database menu, select Set Datasource Location to map the fields on the report to their new names in the data. Then, from the Database menu, select Verify Database to be sure your database is correct. See How do I use the Set Location and Verify Database features for Crystal reports or subreports that use an ODBC DSN? for more information on this process.
    Note: If you do not own Crystal Reports or you are not comfortable with setting the location yourself, your business partner can modify the report to use the new descriptions or you can change the descriptions back to how they originally appeared in the software.

Option 2 - Change the descriptions back to the default:

  1. In Project Management, from the Contract Control menu, select Commitments.
    Note: The title of this menu item may have been changed to another title such as "Purchase Orders" in Custom Descriptions (File, Company Settings, Custom Descriptions).
  2. Click List. Select a commitment that is a purchase order. Click OK. Click OK again if the message "Invoices have been generated against this Commitment..." appears.
  3. Click Header.
  4. Click in the appropriate box and click Change Desc. Type the description exactly as it originally appears in the software using the lists below as guides.

    Left column boxes:
    Ordered by
    Terms
    Ship via
    Free on board
    Misc alpha 5


    Right column boxes:
    Delivery date
    Misc date 2
    Misc date 3

  5.  

    Click OK after you type the description.
  6. Repeat steps 4 and 5 for all descriptions that you need to change. Click Save Commitment when done.

Option 3 - User role does not have ODBC access:

See Error: "Failed to retrieve data from database" / "Failed to retrieve data set" / "Report operation failed" (Role does not have ODBC Read access)

Steps to duplicate
Related Solutions

Error: "Failed to retrieve data from the Database" (Troubleshooting)