Error: "Commitment item [x] does not exist" sending Purchasing invoices to AP
Description

In versions 25.1 and later, we updated the rejection message to reflect the correct issue. The message now reads "Job [job ID] for commitment item [commitment item ID] is closed".

Cause

Job Cost shows the job status as Closed. The job must have the In Progress status.

Resolution
  1. In Job Cost, from the Setup menu, select Jobs.
  2. Select the job your commitment is for.
  3. Click the Status tab.
  4. Change the Status to In Progress.
  5. Click Save.
  6. Click Close.
  7. Go to Tools, Import, Commitments. If the file doesn't default to "JCCommit.txt", click the [...] button and search for the JCCommit.txt file.
  8. In Purchasing, from the Tasks menu, select Post invoices to Accounts Payable.
  9. Click Post.
  10. Click OK when prompted with the "Update to accounting complete" message.

 

[BCB:156:Chat 300 CRE US:ECB]
Steps to duplicate
Related Solutions

Error: "Job [job ID] does not exist..." rejections in AP Import Invoices