Error: "Job [job ID] does not exist/Extra [extra ID] does not exist/Cost Code [cost code ID] does not exist" (rejections in AP Import Invoices or when sending invoices to AP from another application or software)
Description
This issue may present as the following messages:
  • Error: "Job job ID does not exist"
  • Error: "Extra extra ID does not exist"
  • Error: "Cost Code cost code ID does not exist"
  • False "job does not exist" message
  • False "extra does not exist" message
  • False "cost code does not exist" message 
Cause

This may be caused by one of the following:

  • The Job has a status of Closed in Job Cost
  • The Extra has a status of Complete in Job Cost
  • The Cost Code has a status of Complete in Job Cost
Resolution
If the Job, Extra, and/or Cost Code are correct for the invoice you are attempting to import or send, change the Status of the Job, Extra, and/or Cost Code to In progress, then perform your import or send task again.

  • For Jobs: JC Setup, Jobs, Status tab
  • For Extras: JC Setup, Extras, General tab
  • For Cost Codes: JC Setup, Cost Codes, General tab



[BCB:156:Chat 300 CRE US:ECB]



Steps to duplicate
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