Error: "Job [job ID] does not exist..." rejections in AP Import Invoices
Description

Invoices reject when importing or sending invoices to Accounts Payable from another application or software. The invoices reject with a job, extra, or cost code doesn't exist message when they do exist in Job Cost.

This applies to programs like Sage 300 CRE Purchasing (PO), Sage Paperless Construction, TimberScan, and any third-party software using the API. The API is the Application Programming Interface from the Development Partner Program (DPP) Software Developer Kit (SDK).

This issue may present as the following messages:

  • Error: "Job job ID does not exist"
  • Error: "Extra extra ID does not exist"
  • Error: "Cost Code cost code ID does not exist"
  • False "job does not exist" message
  • False "extra does not exist" message
  • False "cost code does not exist" message

 

In version 25.1, we updated these messages to show the correct message.

  • "Job [job ID] is closed"
  • "Extra [extra ID] is completed"
  • "Cost Code [cost code ID] is completed"
  • "Job [job ID] for commitment item [commitment item ID] is closed"
Cause

Possible causes

  • The Job has a status of Closed in Job Cost
  • The Extra has a status of Complete in Job Cost
  • The Cost Code has a status of Complete in Job Cost
Resolution

If the Job, Extra, and/or Cost Code are correct for the invoice you're attempting to import or send, change the Status to In progress. After changing the status, perform your import or send task again.

  • For Jobs: JC Setup, Jobs, Status tab
  • For Extras: JC Setup, Extras, General tab
  • For Cost Codes: JC Setup, Cost Codes, General tab

 



[BCB:156:Chat 300 CRE US:ECB]





Steps to duplicate
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