INTERNAL: Error: "An error occured while retrieving the data for entity FilterReference and operationSet FilterReference_SelectByName in EntityService::GetEntityData" (Security Administration)
Description
Cause

The Global folder is corrupt.

Resolution
  1. Have all users log off Sage 300 CRE and Sage Estimating.
  2. Use the Pervasive Monitor Utility to confirm all users are out. See article 17257, DocLink: How do I use the Pervasive Software Monitor utility (PMU/PSMU) to unlock or close a file on a remote file server from a workstation?
  3. Once all users are confirmed out, verify that the Global folder and its subfolders have no ~PVWS~.loc file. If this file exists, and step 2 shows no file in use, then delete this file.
    • On a Windows Vista or newer operating system, the Global folder is located at C:\ProgramData\Sage\Timberline Office\9.5\Accounting\Global
    • On a Windows XP operating system, the Global folder is located at C:\Documents and Settings\All Users\Application Data\Sage\Timberline Office\9.5\Accounting\Global
  4. Verify the permissions of all subfolders and files in Global\PVData that all users have full control access. This includes any renamed files that may exist.
    Note: During the launch of the program, it scans all the files and folders inside the Global\PVData for permissions.
  5. Verify that the company data folder also has no ~PVWS~.loc file. These are the folders in the prompt that usually comes up when you first launch the software. If this file exists, and step 2 shows no file in use, then delete this file.
  6. If the issue persists, test with a blank Global folder and rename the CPL.xsr file. Contact a Sr. Analyst for assistance.
  7. If the issue disappears after replacing the Global folder with a blank one, IT can restore the Global folder and the CPL.xsr (located C:\ProgramData\SAGE\TIMBERLINE OFFICE\9.5\Shared\Config) in its entirety from a known good full backup. Warn users that they may need to re-setup some security or company folders back to the list if the Global folder is not recent.
DocLink: INTERNAL: Tracking cases where Sage 300 CRE Security has to be rebuilt

[BCB:12:Chat 300 CRE US:ECB]
Defect ID
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