How to prepare data and credit cards for upgrade. Error with CI_SageExchange or CI_SageExchangeProcessing
Description
Cause

It is highly recommended that history in excess of 7 to 10 years be purged if possible for all modules. Bringing in an excess amount of years of data can result in errors during conversion. It is imperative that all steps be completed in their entirety to get the data as clean and prepared for the conversion into Sage 100.

Resolution
[BCB:1:Backup warning:ECB]
  • Verify Sage 100 is at the minimum level required for Conversions:
    • Sage 100 2013 must have PU6 or above
    • Sage 100 2014 must have PU2 or above
    • Sage 100 2015 must have PU1 or above
  • Prep Process:
    1. Logon to Source Version and verify full version
    2. From Menu bar click on Help, About MAS 90, MAS200
    3. Validate that the version is at the minimums required for upgrades:
      • For 4.30 must be at a minimum of 4.30.0.18
      • For 4.40 must be at a minimum of 4.40.0.1
      • For 4.50 must be at a minimum of 4.50.0.0
    4. Open Library Master, Main, User Maintenance
    5. Note the Roles assigned to the User account that will be doing the migration/conversion
    6. Open Library Master, Main, Role Maintenance
    7. Select from lookup the Role assigned in User Maintenance
    8. For Tasks, Security Events, and Module Options verify that full access to everything is granted
    9. Make necessary changes and exit Role Maintenance
    10. Open Library Master, Utilities, Rebuild Key Files
    11. Press the Ok button to the warning message
    12. Enter Company Code, Module Code, press enter for the table list to populate
    13. Select All, Proceed
    14. Repeat for each company that will be migrated to Sage 100
    15. Open Library Master, Utilities, Rebuild Sort Files
    16. Press the Ok button to the warning message
    17. Select Module Code, enter Company Code, Proceed
    18. For any prompts that come up the answer is always Yes
    19. Open Library Master, Utilities, Analyze & Relink Files
    20. Press the Ok button to the warning message
    21. Select Module Code, Company Code, All, Proceed
    22. Open Accounts Receivable, Setup, Payment Type Maintenance
    23. Go through the Payment Types defined and delete any invalid Types that are no longer associated with a valid Merchant and Processor ID
    24. Open Library Master, Main, Company Maintenance
    25. Select the company code that will be migrated and click on the Preferences tab
    26. Press the Credit Card Encryption button
      • Warning: Any changes will impact your customer credit card numbers. Verify that no credit card processing is in progress. Do you want to continue?
      • Press the Yes button once verified no processing is currently being done
    27. Choose one of the following actions for the credit card data
      1. To RETAIN Credit Card data from Company Maintenance
        1. Press the Generate Key button
        2. Do you want to create a new public key? Yes, Accept
        3. You have changed the public key for company XXX. All customer credit card numbers for company XXX will be re-encrypted with the new key. Verify that no credit card processing is in progress. Do you want to continue? Press Yes, Accept in Company Maintenance and exit
          • New public keys are stored in system files. If you are re-migrating a company, you will also need to re-migrate system files after generating a new public key.
      2. To RETAIN only specific data and remove expired credit cards complete the following
        1. Open Accounts Receivable, Utilities, Clear Credit Card Information
        2. Select Clear Expired Credit Cards
        3. Enter Clear Credit Cards Expired on or Before desired date
        4. Select Clear Credit Card History
        5. Enter Clear Credit Card History Dated on or Before desired date
        6. Select Clear Credit Card Settlement Report Records
        7. Enter Clear Credit Card Settlement Report Records posted to G/L on or Before desired date
      3. To DELETE Credit Card Data from Company Maintenance
        1. Press the Delete Key button
        2. Deleting the public key will also delete all customer credit card information for company XXX. This process is irreversible. Do you want to continue?
        3. Press the Yes, press Accept in Company Maintenance and exit
      4. To DELETE any other data that may exist do the following
        1. Open Accounts Receivable, Utilities, Clear Credit Card Information
        2. Select Clear Expired Credit Cards
        3. Enter Clear Credit Cards Expired on or Before desired date
        4. Select Clear Credit Card History
        5. Enter Clear Credit Card History Dated on or Before desired date
        6. Select Clear Credit Card Settlement Report Records
        7. Enter Clear Credit Card Settlement Report Records posted to G/L on or Before desired date
    28. Credit Card Dataset Prep Process Completed
    29. Proceed with Parallel Migration
    30. Proceed with Conversion
DocLink: How to Rebuild Sort Files
DocLink: How to Analyze and Relink Line Files
DocLink: How to Rebuild Key Files in Sage 100
DocLink: How to delete Credit Card Data after a failed conversion. "05.00.00.00:Data::CI_SageExchange:..." or " 05.00 XXX Company Data Conversion", "Error 12"
Defect ID
Steps to duplicate
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