Error: "Client does not have permissions to send as this sender" in Chilkatlog
Description
Cause
  • Paperless Office, Form Maintenance may not have been set up correctly.
  • The default email user setup in Company Maintenance does not have permissions from the SMTP server to email as the "From" E-mail account set up for Paperless Electronic Delivery
  • The actual form's Paperless Office Delivery Options settings has the wrong e-mail address
  • The "From" e-mail address cannot be used due to security/rights restrictions on the SMTP server, or the address is not in the domain (this may occur to a change in domain or SMTP provider)
Resolution

Note: There are numerous different server programs and providers that provide the services of an SMTP e-mail server. Sage does not test Sage 100 with all e-mail services/programs/providers. Sage 100 Customer Support is not responsible for knowing the exact combination of program or provider, security or permission settings, inbound or outbound rules, account logins, passwords, bandwidth restrictions, etc. to enable successful e-mail delivery. The specifics of services, programs, and providers are subject to change. If an error is encountered, troubleshoot based on the Chilkat error log information. You may need to try various settings, or test an alternate service, program, or provider.

Verify Form Maintenance:

Confirm the "From" E-mail Address in P/L Form Maintenance is correct:

  1. Open Paperless Office, Setup, Form Maintenance
  2. Click, Form Entries (flashlight) button
  3. Select the Company/Module/Document in question (XXX, S/O, Invoice)
  4. Verify the From E-mail Address
  5. Click, Accept

Verify Form Code(s):

If Form Maintenance is setup correctly and the error still occurs, check the form code(s) in (for example) Invoice Printing:

  • Example:
    1. Open Sales Order, Main menu, Invoice Printing
    2. Select, Form Code in question
    3. Select a Paperless Office Output which will "Electronically Deliver"
    4. Click, Electronic Delivery button to the right of the Paperless Office Output
    5. Verify the From E-mail Address is correct for this form
    6. Click, OK
    7. Repeat for other impacted forms
  • Note: See the Related Resources section for more information.

Verify with the SMTP server provider:

  • The proper permissions may need to be set by the provider. Or, if they were previously set correctly, permissions may have been changed, unbeknownst to the user, and need to be changed back.

If the error persists, please see the Related Resources below for additional instructions.

DocLink: Wrong "From" e-mail address is being used by Paperless Office, Electronic Delivery
Defect ID
Steps to duplicate
Related Articles