Wrong "From" e-mail address is being used by Paperless Office, Electronic Delivery
Description

If he problem is due to a wrong FROM email address and it appears that it is the On-the-Fly electronic delivery FROM email address changing even when you correct it, this could be a value in the specific form code entry in the SY_REPORTOPTION.M4T file mentioned above.

(based on company key, type of printing - example: AR_STATEMENTPRINTING_UI, and form code)

Check the OptionsString$ field (as above) but look for a "ML_FromEmaiLAddress$=" in the string and see if the address contained there is the "wrong" or "bad" email address. Take note of the current value and then update it with the "correct" one.


Cause
  • Besides the User ID (e-mail address) in Company Maintenance, the "From" e-mail address that is used when forms are sent via Paperless Office Electronic Delivery can be set from Form Maintenance as well as on-the-fly using the Electronic Delivery button from the various forms' Printing task windows.
  • Some e-mail systems will allow multiple "From" e-mail addresses to be used based on one authenticating User ID account (as set in Library Master, Main menu, Company Maintenance, E-mail tab). Others will not.
  • For some cases where the email address is changed on-the-fly, it is stored in the "..\MAS90\MAS_SYSTEM\SY_ReportOption.M4T" file. In some instances, this information needs to be manually cleared from the record in order to prevent the "From" email address from reappearing.


Resolution
[BCB:1:Backup warning:ECB]


Verify the authenticating User ID account or main e-mail address:

  1. Open Library Master, Main menu, Company Maintenance
  2. For Company Code, select the company code being used.
  3. Access the E-mail tab
  4. Verify the User ID holds the correct authenticating account or single e-mail address.
  5. Click Accept to commit changes.

Note: The email being using in the main tab of company maintenance is what will default in PPL, updating this will  initiate a related change in PPL.

Verify the form entry or entries (an entry that better applies would override the authenticating account):

  1. Open Paperless Office, Setup menu, Form Maintenance.
  2. Click Form Entry (flashlight icon) button to see a list of existing entries
    • Note: Do not click the Lookup (magnifying glass) icon to create new entries
  3. Select the entry that most specifically covers the area of concern.
    • Note: For example, an entry for All Companies, All Modules, All Documents would have its more general settings overridden by a more specific entry for a particular Company, the A/R module, and A/R Invoice, if printing A/R invoices for that company.
  4. Access the Main tab
  5. For the From E-mail Address field, verify that the e-mail address is correct.
    • Note: Since Sage 100 uses the User ID (or e-mail address) as entered in Company Maintenance, E-mail tab (see above) to authenticate with the SMTP server, have the SMTP provider/administrator make sure that User ID (e-mail address) has rights to "send as" the From E-mail Address you intend to substitute.
  6. Click Accept to commit changes.

Verify that on-the-fly settings are correct for each specific form (these will override settings in Form Maintenance, which themselves override the User ID (e-mail address) set in Company Maintenance, E-mail tab):

  • Example: Sales Order, Invoice Printing:
    1. Open Sales Order, Main menu, Invoice Printing
      • Note: Do try to access via the Quick Print option from within S/O Invoice Printing
    2. For Form Code, select the affected form code using the lookup
    3. For Paperless Office Output, select "Electronically Deliver Only" from the dropdown list
    4. Click the Electronic Delivery (paperless icon) button to the right of the dropdown list to access the Electronic Delivery for Forms window
    5. For the From E-mail Address field, verify the e-mail address.
      • Note: When on-the-fly settings are created in (for example) Sales Order Printing, Paperless Office Output "Electronic Delivery", Electronic Delivery (paper and barred printer icon) button to access Paperless Office Delivery Options... Then after attempting to Print for a non-"STANDARD" form code, a record will be created in the system file "SY_ReportOption.m4t" (in "..\MAS90\MAS_System", on the server where Sage 100 is installed), stored by Module, CompanyKey, ReportID (name of report, like "SO_SalesOrderPrinting"), and ReportSetting (or Form Code) - but not by Workstation Name! There is a special insert into the OptionsString$ field in the record that stores the details of on-the-fly settings for Electronic Delivery, such as the e-mail address to be used.
      • Note: Since Sage 100 uses the User ID (or e-mail address) as entered in Company Maintenance, E-mail tab (see above) to authenticate with the SMTP server, have the SMTP provider/administrator make sure that User ID (e-mail address) has rights to "send as" the From E-mail Address you intend to substitute.
      • Note: In some cases, if you delete the address and save changes, then go back and find the original (wrong) address still in place, then follow the steps under "If the issue persists".
    6. Print the Form to commit changes for the specific Form Code
    7. Repeat the above steps for any affected form code for Sales Order, Invoice Printing
    8. Verify the settings for all affected forms, such as:
      • Accounts Receivable, Period End menu, Statement Printing
      • Purchase Order, Main menu, Purchase Order Printing
      • Return Merchandise Authorization, Main menu, Customer RMA Printing
      • Sales Order, Main menu, Sales Order Printing

If the issue persists:

  1. Go to Library Master, Main, Data File Display and Maintenance
  2. Select the "..\MAS90\MAS_SYSTEM\SY_Company.M4T" File
  3. Using the Lookup, make note of the affected Company Code and corresponding Company Key
  4. Select the "..\MAS90\MAS_SYSTEM\SY_ReportOption.M4T" File
  5. Locate the affected record based on CompanyKey$, DocumentName$, and Form Code
  6. Once the affected record is selected, Edit the OptionsString$ Field (Field 5).
  7. Look for the BT_EMAIL$="" area.
  8. Delete the incorrect email address from the string and leave blank spaces in its place
  9. Repeat the steps for verifying the on-the-fly settings (see above) to ensure the new Email address sticks

Note: Some e-mail systems will not allow multiple "From" e-mail addresses to be used based on one authenticating account (as set in Library Master, Main menu, Company Maintenance, E-mail tab). Some will return an error message, but others will continue to send the e-mail using the authenticated account. Other email systems may have a setting that cause e-mails to be sent from certain addresses other than the authenticating account, based on custom rules set - which would be outside of Sage 100 Customer Support's scope of expertise.

DocLink: How to use Paperless Office to e-mail customer and vendor forms from Sage 100
DocLink: How to change the "From" E-mail Address for forms in Paperless Office
DocLink: Error: "Client does not have permissions to send as this sender" in Chilkatlog

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