Error: "Data is not selected for report printing" occurs for AR Invoice History Report printing, or it hangs, after upgrade to Sage 100 version 2015
Description
Cause
  • The SY_ReportOption.M4T file in "..\MAS90\MAS_System" may contain corrupted values because company data was migrated without first having Product Update 1 (or higher) already installed for Sage 100 ERP version 2015.
    • Note: Sage Knowledgebase KB 55817 "Download Sage 100 ERP 2015", which contains the download link for Sage 100 version 2015, states that "Product Update 1 or higher must be installed before migrating either system information or company from a prior version", and also contains a link to this knowledgebase entry.

Resolution
[BCB:1:Backup warning:ECB]
[BCB:2:Database warning:ECB]

Note: The following may or may not resolve the issue. Invoice History Printing is not always due to a bad string in the SY_ReportOption.m4t file/table. It could be that invoice history records are corrupted, or there is a problem with the print spooling process or printer, etc.

  • Migrate data only after installing Product Update 1:

    1. Install Product Update 1
    2. Migrate (or re-migrate) company data
  • If re-migrating the data is no longer an option, complete the following steps (Sage 100 ERP Standard and Advanced editions):
    1. Create new support ticket online by logging into the Customer or Partner Portal and selecting the option to Submit A New Case (or, you may call in)

      • Note: Make sure the support ticket is created with fields filled out (Subject, Description of issue, Version, Module, etc.) and saved.
    2. After the support ticket has been created, email the SY_ReportOption.M4T file to [email protected] with the the following Subject line: "Ticket xxxxxxxxxx - DATAFIX" (where "xxxxxxxxxx" is the ticket number)
      • Note: SY_ReportOption.M4T, found in "..\MAS90\MAS_System" where Sage 100 ERP is installed
    3. Sage 100 ERP Customer Support will set the support ticket to "Free of Charge"
    4. Sage 100 ERP Customer Support will attempt to correct and return the corrected file within 4 business hours
      • Note: Exceptions may apply if we receive file after 3:00pm Pacific Standard Time or after normal business hours, or if our support capability is impacted
      • Note: In some cases, the correction attempt does not resolve the issue. That would indicate that the issue being experienced is not the same as that reported in this Sage Knowledgebase KB article. For example, a customized (modified) Crystal Report form may have become corrupted. Or, there is another settings problem.
  • For Sage 100 version 2015 Premium (SQL) editions (do the following in SQL Studio Manager):

    • Determine the affected Company Key:
      • Select * From SY_Company (Note Affected Company Key)
    • How Many Records are affected?
      • Select * from SY_ReportOption
        where optionsString like '%quickprint%'
        and ReportID = 'AR_INVOICEPRINTING_UI'
        and CompanyKey = 000000001 (Replace with the affected CompanyKey)
    • Correct the affected records:
      • Update SY_ReportOption
        set OptionsString = 'BT_DESIGNER$="";DB_PRINTCOMMENT$="P";CB_PRINTBILLOPTIONS$="N";DB_PAPERLESSOFFICEOUTPUT$="1";ELECTRONICDELIVERYOPTIONS$="";BT_EMAIL$="";ML_INVMSG1$="";ML_HISTMSG1$="";ML_INVMSG2$="";ML_HISTMSG2$="";BT_ALIGN$="";ML_BATCHNO$="";ML_WARNING$="Warning - created with previous application version.";MULTIPART$="N";ML_WARNING$="Warning - created with previous application version.";MULTIPART$="N"'
        where optionsString like '%quickprint%'
        and ReportID = 'AR_INVOICEPRINTING_UI'
        and CompanyKey = 000000001 (Replace with the affected CompanyKey)
    • Verify no Remaining Records exist with "Quick Print":
      • Select * from SY_ReportOption
        where optionsString like '%quickprint%'
        and ReportID = 'AR_INVOICEPRINTING_UI'
        and CompanyKey = 000000001 (Replace with the affected CompanyKey)
      • (This should return 0 rows)
    • Test Printing in Sage 100 ERP Invoice History Printing after these statements have been completed and 0 rows are returned after completing the final Select Statement.
DocLink: Error: "Data is not selected for report printing" or all records print when using Quick Print from various forms on Sage 100 version 2015
Defect ID
Steps to duplicate
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