Error: "Data is not selected for report printing" or all records print when using Quick Print from various forms on Sage 100 version 2015
Description
Cause
  • The SY_ReportOption.M4T file in "..\MAS90\MAS_System" contains corrupted values because System Information and company data was migrated without Product Update 1 already installed for Sage 100 ERP version 2015.
    • Note: Sage Knowledgebase KB 55817 "Download Sage 100 ERP 2015", which contains the download link for Sage 100 version 2015, states that "Product Update 1 or higher must be installed before migrating either system information or company data from a prior version", and also contains a link to this knowledgebase entry.
Resolution

A Utility was added to Sage 100 Standard & Advanced 2015.1 and higher to correct the affected records. After the Utility is run, Quick Print should function properly. Use the following procedure to run the Utility:

  1. Click File, Run in Sage 100
  2. Enter SYZCON and click OK
  3. Enter the following command at the prompt:
  • RUN "..\Utility\SY_SaveSettingsQP_utl" and press the Enter key

-A Message window will display asking if the utility should be run for all companies, or be canceled.
-If any invalid entries are found, they will be corrected and a log file will be created in the ..\mas90\HOME\TextOut directory.
-If there are no invalid entries, a message will display stating that fact.

For Sage 100 version 2015 Premium (SQL) editions (do the following in SQL Studio Manager):

  • Enter the following command to verify if OptionsString contains QuickPrint reference:
    • Select * from SY_ReportOption
      where optionsString like '%QUICKPRINT%'
    • Note: If no records are displayed, then another issue is causing error
  • Enter the following command to remove QuickPrint reference from OptionsString:
    • UPDATE SY_ReportOption
      SET OptionsString = REPLACE(OptionsString,'QUICKPRINT$="";','')
      WHERE OptionsString like '%QUICKPRINT$%'
    • Run the previous query to verify there are no records containing QuickPrint

Possible Workaround:

Instead of Quick Printing, print regularly:

  • Example:
    1. Complete a sales order or purchase order. Do not Quick Print.
    2. Open Sales Order (or Purchase Order), Main menu, Sales Order Printing (or Purchase Order Printing)
    3. Enter the Order Number
    4. Click Print

DocLink: Error: “Data is not selected for Report Printing”
DocLink: Error: "Data is not selected for report printing." when Printing Invoices from Invoice History Printing
DocLink: Error: "Data is not selected for report printing" in Sales Order Picking Sheet Printing for specific sales orders

[BCB:155:Chat 100 US:ECB]
Defect ID
104206
Steps to duplicate
1. Enable Paperless Options for PO Forms 2. Open Purchase Order, Main menu, Purchase Order Entry 3. Select an existing Purchase Order 4. Click the Quick Print button 5. Select PDF ALL and click Print
Related Articles