Transaction records missing in Accounts Payable
Description
Cause

File Doctor deleted records with one of the following errors. The negative number can be any negative number, not just -1 in the examples below.

  • "Field "Sequence Number" with "-1" invalid: Negative valued not allowed. Record deleted. Primary key field has a critical error"
  • "Field "Sequence Number" with "0" invalid: Zero value not allowed. Record deleted. Primary key field has a critical error"
  • "Field "Run Number" with "0" invalid: Zero value not allowed. Record deleted. Primary key field has a critical error"
  • "Field "Run Number" with "-1" invalid: Negative valued not allowed. Record deleted. Primary key field has a critical error"
  • "Field "payment id" with "0" invalid: Zero value not allowed. Record deleted. Primary key field has a critical error"
  • "Field "payment id" with "-1" invalid: Negative value not allowed. Record deleted. Primary key field has critical error"
Resolution
  1. Review the File Doctor journal to confirm the issue.
  2. Restore a data backup from before when you ran File Doctor. When restoring to a backup, restore the entire company data folder, not just AP.
  3. Contact Sage Support to request a file fix.

If you can't restore a backup from before running File Doctor, you’ll still need a file fix. The file fix can take longer because the data specialist has to recreate the deleted transactions. Provide the File Doctor journal for the file fix.




[BCB:156:Chat 300 CRE US:ECB]

 

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