Error: "The image attached to this asset has been deleted or moved. Would you like to reattach the image"
Description


Cause
  • Attachment Path is\was set to Drive letter on the server.
  • Database was renamed which changed the Service ID in the System database
Resolution

In Sage Fixed Assets:

  1. On the Asset Detail view of an asset with an attached PDF, click the Image tab, the Reattach Image.... message appears.
  2. Click Yes, click Reattach, select the PDF file with the matching Image Name (See Additional Information), click Open, click Close on the Image Manager.
  3. In Windows Explorer: Browse to the Attachments path and note the changes made in the reattached PDF file.

    What you will see is the value for the first and\or second values of the file name has been changed - Renaming all the files to the same values as the reattached PDF will allow the program to access those files again without going through the Reattach process.

 

Image files in the Attachment Folder: When a PDF file is attached to the program, it will be copied to the Attachments Path location and be renamed in the following format:

---

  • ServiceID - is the index field used in the System Database to identify the Database file.
  • CompanyID - is the index field used in the Asset Database to identify the Company within the database.
  • ImageID - is the index field used in the Asset Database to identify the specific Image
  • Image Name - is the name entered by the user when the Image was added to the Image Manager

[BCB:165:Chat Fixed Assets US:ECB] 

Steps to duplicate
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