Business Insights Explorer Views appear blank or no data appears in panes
Description
Cause
  • Damaged Registry Keys for BIE Explorer

  • Damaged Explorer Views files
  • Damaged Sage 100 settings or workstation install

 

Resolution

[BCB:5:Third-party support:ECB] 

Delete Damaged Registry Subkey

  1. In the Windows Search, type Regedit. Then select Registry Editor.
  2. Go to HKEY_CURRENT_USER\Software\Sage Software\BIE Explorer\Explorer.
  3. Delete this key.
  4. Check for blank views. If Standard View shows blank, refer to Business Insights Explorer Views appear blank.
  5. Open HKEY_CURRENT_USER\Software\Sage Software\BIE Explorer\Products\MAS90.
  6. Confirm that the correct ViewsPath is set by checking the ViewsPath value.

Recreate the Sage 100 Folder

  1. Right-click the Windows Start and select File Explorer.
  2. Go to the user's Documents folder.
  3. Find the Sage 100 folder and rename it to xSage 100.
  4. Launch Sage 100 and log in.
  5. When prompted, choose Standard Mode as the view.
    • Sage 100 will create a new folder in the user's Documents folder
  6. Go to Business Insights, Explorer Views and confirm everything is working.
  7. Log out of Sage 100.
  8. If you created favorites, access the renamed xSage 100 folder in the users Documents folder.
  9. Copy the favorites.json file to the newly created Sage 100 folder.

Copy working Views over

Important:

  • This will only work if the issue appears to be with a specific view or views
  • These steps require access to an additional working installation
  • The Views don't exist or the incorrect path is in the Windows Registry

Follow the steps below to copy the views from a working computer

  1. Right-click the Windows Search and type Regedit.  Select Registry Editor from the list.
  2. Go to HKEY_CURRENT_USER\Software\Sage Software\BIE Explorer\Products\MAS90.
  3. Check the ViewsPath value to confirm the path is correct.
  4. If the path is missing or wrong, update it or copy Views folders from a working machine.
  5. Compare the ViewsPath value with a working machine to identify differences.
  6. Go to ...\MAS90\BIExplorer\Views on the Sage 100 server and check if view files exist.
  7. Copy a view file from a working install and replace the local one.
  8. For newer versions, use C:\ProgramData\Sage\BIE Views as the local path.

The issue occurs on one workstation

  1. In the Windows Search type Control Panel, and select Control Panel from the list.
  2. In the Control Panel, select Programs and Features.
  3. Uninstall the Sage 100 Workstation Setup client.
  4. Rename any leftover folders like Sage 100 on the workstation's C:\Users\ \Documents or the MAS90 folder.
  5. Run the Sage 100 Workstation Setup client. Right-click Autorun.exe and select Run as Administrator.

(Premium only) Verify the MAS_Reports user has db_datareader accesses

  1. Log into SQL Server Management Studio with the sysAdmin role.
  2. Expand Security, Logins.
  3. Right-click MAS_Reports then select Properties.
  4. On the left panel, select User Mapping under Select a page
  5. Verify the user has db_datareader and public access to all MAS_* databases.
  6. If the user doesn't have db_datareader access, perform the following steps for each database.
    • Select 'New Query' from the toolbar
    • Copy/Paste the following SQL query into the New Query window
      --begin

      --Reset MAS_Reports permissions to Database

      EXEC sp_dropuser 'MAS_Reports'
      GO
      EXEC sp_grantdbaccess 'MAS_Reports'
      GO
      -- Assign db_datareader permissions to the user
      EXEC sp_addrolemember 'db_datareader', 'MAS_Reports'
      GO
      -- Set the default schema to dbo for the user
      ALTER USER MAS_Reports WITH DEFAULT_SCHEMA = dbo;

      --end
    • From the dropdown list on the toolbar, select Database that user doesn’t have db_datareader permissions
    • Click Execute to run the query
    • Select each database the user doesn't have db_datareader permissions and click Execute to run the query
  7. Log back into Sage 100 and verify the data appears on the BI Explorer view.

 (Advanced/Premium) Verify the Sage 100 client isn't using XP Compatibility mode

  1. Right-click the Sage 100 shortcut and select Properties.
  2. Click the Compatibility tab.
    • If there’s a check in Run this program in compatibility mode for
    • Select Change settings for all users
  3. Uncheck Run this program in compatibility mode for.
  4. Click OK twice to save settings.
  5. Log back into Sage 100 and verify BIE views display data.

Unblock the App in Windows Defender

  1. In the Windows Search, type Windows Security.
  2. Select Enter to open.
  3. Select Virus & Threat Protection from the left navigation pane.
  4. Under Virus & Threat Protection settings, select Manage Settings to view and adjust your settings.

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