Error: "This program has quit. Invalid form field number [TS 5618]" (in AP Enter Pending Invoices)
Description

Accounts Payable Enter Pending Invoices task aborts when you select a specific pending invoice session. This only occurs on a specific pending invoice session. New sessions open without issue.

Cause

This usually occurs due to:

  • You resized the Pending Invoices task window too small and saved to that pending invoice session.
  • You have a corrupt pending invoice in the new.api file.

Confirm the abort occurs for other users in the same company data folder before proceeding with the solution below.

If the abort occurs when tabbing or entering to the distribution grid, don't use the steps below.

Resolution

You have the Pending System setting set to Multiple Users

  1. In Accounts Payable from the Tasks menu, select Enter Pending Invoices.
  2. In the Session field, enter a new session ID. For example: test.
  3. In the box Select any or all additional sessions from the list below, select the problem session ID.
  4. Click OK. Confirm the pending invoice window opens correctly, at full size.
  5. Delete the last invoice.
  6. Click Finish.
  7. Go back into Enter Pending Invoices.
  8. Select the problem session ID.
  9. Click OK. Confirm the pending invoice window opens correctly, at full size. If it doesn’t, there can be more invoices contributing to the problem. Repeat the steps, deleting the last invoice, until you resolve the error.
  10. Re-enter the invoice that you deleted, if needed.

Alternative workaround

Instead of deleting invoices, you can use just steps 1-4 to access your invoices. Use the new session ID from step 2 and select the problem session ID as an additional session to access those invoices.

You have the Pending System setting set to Single User

You don't have pending invoices

  1. Go to Accounts Payable, Inquiries, Invoice Inquiries, Pending Invoice Register.
  2. Verify that you have no pending invoices.
  3. Verify that you don't have any other unposted invoices.
  4. If you confirm both, rename the new.api and create a new one.

You have pending invoices without commitments

  1. Go to Accounts Payable, Inquiries, Invoice Inquiries, Pending Invoice Register.
  2. Verify that you have no pending invoices that include commitment information.
  3. Verify that you don't have any other unposted invoices.
  4. If you confirm both, and you can reenter pending invoices, rename the new.api and create a new one.

If you do not want to reenter the pending invoices and/or you have other unposted invoices, contact Sage Support. We’ll request a copy of your data files for evaluation to determine how to fix.

You have pending invoices with commitments

  1. Go to Accounts Payable, Inquiries, Invoice Inquiries, Pending Invoice Register.
  2. Verify if you have pending invoices with commitment information.

If you do have commitment-related pending invoices, contact Sage Support. We’ll request a copy of your data files for evaluation to determine how to fix.

 

 

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Steps to duplicate
Related Solutions

Error: "Invalid form field number [TS 5618]" (in AP tasks)