Error: "PMDataAccessLayer Error creating temporary file in [data folder directory]\tmp[number]"
Description
Cause

The Activate Interface for Property Management (PM) is turned on in AP Settings.

When the Activate Interface for PM is turned on, the DM Classification task that creates the AP Invoice creates a temp file/folder inside the company data folder for PMT files.

The tmp files are named tmp01, tmp02, tmp03, etc.

Resolution

[BCB:1:Backup warning:ECB]

 

  • Delete the tmp files inside the company data folder and the corresponding tmp folders inside the PVData folder.
    • Note: When you close Sage Desktop, it should automatically delete those tmp files/folders. If it does not, manually delete them through Windows Explorer. 
    • Warning: Use extreme caution when deleting or moving files. Deleting or moving the wrong files can cause data corruption. If you need assistance, contact your network administrator or Sage 300 Construction and Real Estate consultant.
  • If you are not using the Chargeback feature for AP and PM, turn off (unmark) the Activate Interface for Property Management in AP Settings, Post and Interface Settings.
    • Note: Chargebacks is a feature in AP that allows you to charge back (or bill back) a portion of or all of the invoice to a tenant in PM. When Chargeback (CB) is selected for invoice distribution, it will create a charge for the tenant in PM.
  • If you use the Chargeback feature for AP and PM, perform the DM scanning and classification on the server instead of the workstation/terminal server.

 

Steps to duplicate
Related Solutions

Error: "PMDataAccessLayer Error creating temporary file" (when entering, changing, or posting invoices in AP)
Error: "PMDataAccessLayer Error creating temporary file" (during PM Trial run tasks)