Error: "PMDataAccessLayer Error creating temporary file" (during PM Trial run tasks)
Description
Cause

This may be caused by one or more of the following:

  • There are tmp files left over from previous trial run tasks that did not get removed.
  • If the Trial run tasks works on one machine and the server but does not work on another machine, there could be a problem with the Actian/Pervasive engine install or configuration.

There may be other causes that have not yet been identified.

Resolution
[BCB:1:Backup warning:ECB]


Remove left over tmp files/folders:

  • The Trial run tasks in Property Management copies data into temp files to perform the trial run, then removes the temp files when finished. In versions 15.1 and newer, when ran on a workstation, these temp files are created inside the company data folder. When ran on the server, these temp files are created in the temp directory on the server (i.e. C:\Windows\Temp). (Refer to How is the Property Management Trial Run task different from the Create Entries task? for more information.) The files will appear as tmp, tmp0, tmp1, tmp2, tmp3, etc in the root of the company data folder or C:\Windows\Temp. There will also be corresponding folder names inside the PVData folder in that same location. Delete these tmp files/folders from both locations (root of the company data folder and PVData, or C:\Windows\Temp and C:\Windows\Temp\PVData).
  • WARNING: Make sure only the files and folders named tmp (example: tmp, tmp0, tmp1, tmp2, etc) are the ones being removed.

If removing the tmp files/folders does not resolve the issue, refer to the Related Resources section for other possible causes and solutions.

If the issue remains unresolved, contact Sage 300 CRE Customer Support for additional troubleshooting.



[BCB:156:Chat 300 CRE US:ECB]

Steps to duplicate
Related Solutions

Error: "Aborted. I/O error" or "Failed" (during PM Trial Run tasks)
Error: "PMDataAccessLayer Error creating temporary file" (when entering, changing, or posting invoices in AP)
Property Management errors: "Error creating temporary file..." / "Could not open temporary file" / "I/O error" (MASTER ARTICLE)
Error: "PMDataAccessLayer Error creating temporary file" (corrupt Pervasive/Actian install)
Error: "PMDataAccessLayer Error creating temporary file" (stranded tmp files)
Error: "This program has quit. I/O error." (during PM trial run tasks - Malware Bytes or antivirus)
Error: "PMDataAccessLayer Error creating temporary file" (during DM classification)