Error: "Aborted. I/O error" or "Failed" (during PM Trial Run tasks)
Description

This only appears to affect Terminal Servers or Remote Desktop Services (RDS) or other remote connections. However, it can occur on workstations that don't use a remote connection. The tasks work on the main data server.

The Trial Run tasks include:

  • Generate Rent Roll
  • Generate Late Charges
  • Calc Management Fees
  • Accrue Interest
  • Pay Interest
  • Pull Expenses from GL
  • Reconcile and Escalate
  • Recoverable Expenses
  • Escalate by CPI
  • Escalate by Porters' Wage
  • Bill Percentage Rent
  • Recalc Pct Rent
Cause

Windows Security Real-Time Protection is active on the terminal server, RDS server, or workstation. Security blocks the pm.exe process.

Resolution

CAUTION:

This solution requires advanced knowledge of Windows security and network settings. Sage isn't responsible for any issues that arise from changes to these settings. Ensure you back up all system and application databases necessary for a complete restoration. It's advisable to contact a certified consultant or your system administrator for assistance.

Update Windows security

Add the pm.exe as a Process exclusion in Windows Security.

The following steps can vary by Operating System or as Microsoft changes Windows Security or Windows Defender. Refer to the Microsoft Knowledgebase to find specific instructions to add a process exclusion.

  1. On the machine where the issue occurs, close all open programs.
  2. Open Windows Security.
  3. Select Virus & Threat Protection.
  4. Under Virus & threat protection settings, click Manage settings.
  5. Scroll down to Exclusions.
  6. Click Add or remove exclusions.
  7. Click Add an exclusion.
  8. Select Process.
  9. In the Enter process name field, type pm.exe, then click Add.
  10. Close out of Windows Security. Log off Windows and back in to confirm the changes take effect.
  11. Have the user login to Sage 300 CRE and test the Property Management trial run task.

If this doesn’t resolve the issue, add the Sage recommended file and folder exclusions to Windows Security or Windows Defender. Work with your IT professional if you need assistance.

Workaround

Run the task from the server.

Other possible causes and solutions

 

[BCB:156:Chat 300 CRE US:ECB]



Steps to duplicate
Related Solutions

Property Management errors: "Error creating temporary file..." / "Could not open temporary file" / "I/O error" (MASTER ARTICLE)
How is the Property Management Trial Run task different from the Create Entries task?