Error: "Aborted. I/O error" or "Failed" (during PM Trial Run tasks)
Description

Cause

Windows Security Real-Time Protection is active on the terminal server/RDS server/workstation and is blocking the pm.exe process.

Resolution
[BCB:3:Network warning:ECB]

Add the pm.exe as a Process exclusion in Windows Security:

NOTE: The following steps may vary by Operating System and/or as Microsoft makes changes to Windows Security/Windows Defender. Refer to the Microsoft Knowledgebase to find specific instructions for adding a process exclusion to Windows Security.

  1. On the machine where the issue occurs, close all open programs.
  2. Open Windows Security.
  3. Select Virus & Threat Protection.
  4. Under Virus & threat protection settings, click Manage settings.
  5. Scroll down to Exclusions.
  6. Click Add or remove exclusions.
  7. Click Add an exclusion.
  8. Select Process.
  9. In the Enter process name field, type pm.exe, then click Add.
  10. Close out of Windows Security.
    • Note: You may need to log off Windows and back in for the changes to take full effect.
  11. Have the user login to Sage 300 CRE and test the Property Management trial run task.

If this does not resolve the issue, add the Sage recommended file and folder exclusions to Windows Security/Windows Defender. For the list of folders and files, refer to What Sage 300 Construction and Real Estate and Sage Estimating files and folders should I exclude from my antivirus software scan?

Contact your IT consultant or network administrator about setting up the exclusions in Windows Security/Windows Defender.

WORKAROUND: Run the task from the server.

 

For other possible causes and solutions:


[BCB:156:Chat 300 CRE US:ECB]

Steps to duplicate
Related Solutions

Property Management errors: "Error creating temporary file..." / "Could not open temporary file" / "I/O error" (MASTER ARTICLE)
How is the Property Management Trial Run task different from the Create Entries task?