Error: "PMDataAccessLayer Error creating temporary file" (stranded tmp files)
Description
Cause

There are tmp files inside the data folder and/or tmp folders inside the PVData folder which should not exist.

There are tasks that temporarily create these tmp files/folders but then are removed when the task finishes.

They may not have been removed due to a previous abort or other error.

Resolution
[BCB:1:Backup warning:ECB]
[BCB:2:Database warning:ECB]
[BCB:3:Network warning:ECB]

WARNING: Contact your network administrator, Sage 300 Construction and Real Estate Consultant, or Sage 300 Construction and Real Estate Customer Support for assistance with deleting the appropriate files.

  1. Locate the data folder directory from Help, About...
  2. Note the Current Data Folder.
  3. Browse to the data folder in Windows Explorer (or File Explorer).
  4. Delete the tmp files found inside your data folder directory. The tmp files may appear as tmp, tmp0, tmp1, tmp2, tmp3, tmp4, etc.
  5. Inside your data folder is a PVData folder. Delete the tmp folders found inside this PVData folder. The tmp folders may appear as tmp, tmp0, tmp1, tmp2, tmp3, tmp4, etc.
  6. Verify you can now complete your task without error.

If there are no tmp files/folders or this does not resolve the issue, refer to the Related Resources section for other possible causes and solutions.

DocLink: Error: "PMDataAccessLayer Error creating temporary file" (when entering, changing, or posting invoices in AP)
DocLink: Property Management errors: "Error creating temporary file..." / "Could not open temporary file" / "I/O error" (MASTER ARTICLE)
DocLink: Error: "PMDataAccessLayer Error creating temporary file" (corrupt Pervasive/Actian install)
DocLink: Error: "PMDataAccessLayer Error creating temporary file" (during DM classification)
DocLink: Error: "PMDataAccessLayer Error creating temporary file" (during PM Trial run tasks)

[BCB:156:Chat 300 CRE US:ECB]
Defect ID
Steps to duplicate
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