Error: "This program has quit. I/O Error. Pervasive Status Code 171"
Description
Cause

The workstation isn’t on a domain.

This error can also occur if you install the Sage server on Microsoft Intune rather than a Windows Domain.

 

Resolution

CAUTION:

This solution requires advanced knowledge of Windows security and network settings. Sage isn't responsible for any issues that arise from changes to these settings. Ensure you back up all system and application databases necessary for a complete restoration. It's advisable to contact a certified consultant or your system administrator for assistance.

 

Identify an administrator user account and add it to the workstation’s User Accounts and Actian services.

  1. At the server, go Start, Control Panel.
  2. Select User Accounts.
  3. Select Manage User Accounts or Manage another account.
  4. Locate an Administrator account. You’ll need the account name and password for this account. This can be the default Administrator account or another account that is an administrator on the server.
  5. At the workstation, go to Start and Control Panel.
  6. Select User Accounts.
  7. Select Manage User Accounts or Manage Another Account.
  8. Click the Add button or Create a new account.
  9. Enter the administrator’s username and password exactly as they exist on the server.
  10. Select Administrator for the account type.
  11. At the workstation, go to Start, Run, then type in SERVICES.MSC and click OK.
  12. From the list of Services, right-click Actian PSQL Client Engine and select Properties.
  13. From the Log On tab, select Log on as: This account:
  14. Enter the user account username and password that you created in step 2 and click OK.
  15. Right-click Actian PSQL Client Engine service and select Restart.
  16. Launch Desktop to verify that the error no longer occurs.
Steps to duplicate
Related Solutions

Error: "This program has quit. I/O Error. Pervasive status code 170" or "Pervasive status code 171"