Error: "This program has quit. I/O Error. Pervasive status code 171" (workstation not on a domain)
Description


Cause

The workstation is not on a domain.

This error may also occur if the Sage server is installed on Microsoft Intune rather than a Windows Domain.

Resolution
[BCB:3:Network warning:ECB]

Identify an administrator user account and add it to the workstation’s User Accounts and Actian services:

  1. Locate an administrator user profile. This can be the default Administrator account or another account that is an administrator on the server:
    1. At the server, go Start, Control Panel.
    2. Select User Accounts.
    3. Select Manage User Accounts or Manage another account.
    4. Locate an Administrator account. You will need the account name and password for this account.
  2. Add the administrator account credentials to the workstation:
    1. At the workstation, go to Start, Control Panel.
    2. Select User Accounts.
    3. Select Manage User Accounts or Manage Another Account.
    4. Click the Add.. button or Create a new account.
    5. Enter the administrator’s username and password exactly as they exist on the server and select Administrator for the account type.
  3. On the workstation: Add the administrator account credentials to the Log on tab of the Actian service:
    1. At the workstation, go to Start, Run, then type in SERVICES.MSC and click OK.
    2. From the list of Services, right-click Actian PSQL Client Engine and select Properties.
    3. From the Log On tab, select Log on as: This account:
    4. Enter the user account username and password that you created in step 2 and click OK.
    5. Right-click Actian PSQL Client Engine service and select Restart.
  4. Launch Desktop to verify that the error no longer occurs.
Steps to duplicate
Related Solutions

Error: "This program has quit. I/O Error. Pervasive status code 170" or "Pervasive status code 171"