Error: "This program has quit. I/O Error. Pervasive status code 170" or "Pervasive status code 171"
Description

Cause

Note: Pervasive status code 170 and 171 errors generally occur due to a problem at the local workstation. This may be due to a number of reasons, but the usual causes are:

  • Another Windows profile being logged in at the same workstation. Note that using "Switch User" is not supported. You must log off a Windows user before you can log on another if this is a workstation operating system.
  • The Pervasive preload/processor isn't started on the workstation. This is only for versions 14.1 and older.
  • Pervasive/Actian on the local workstation is corrupt.
  • Pervasive/Actian is communicating over a wireless network.
  • Pervasive/Actian at workstation not running with domain administrator privileges.
Resolution
[BCB:3:Network warning:ECB]


Important:  If you use version 16.1 or earlier, see Potential security vulnerability with Pervasive System Analyzer

Before beginning, consider:

  • If issue is only occurring at one workstation, then reboot that machine. If rebooting does not resolve the issue, follow the troubleshooting steps below.
  • If issue is happening to all users on all computers, have all Sage 300 and Sage Estimating users exit the Sage products and restart the Pervasive/Actian services at the file server.
    1. Click the Windows start menu, Search programs and files, type in: services.msc and click OK.
    2. Locate the Pervasive/Actian services and stop and start them (in no particular order).

Resolution:

  1. Log on the affected workstation as an administrator.
  2. If the computer is connected to a wireless network, connect it to the network with an ethernet cable and disable the wireless adapter.
  3. Stop and start Pervasive/Actian:
    • For versions 15.1 and later:
      1. Click the Windows start menu, Search programs and files, type in: services.msc and click OK.
      2. Locate the Pervasive/Actian services and stop and start them (in no particular order).
    • For versions 14.1 and earlier:
      • Click the Windows start menu, All Programs, Pervasive PSQL 11, Engines, Stop PSQL Workgroup Engine.
      • Click the Windows start menu, All Programs, Pervasive PSQL 11, Start PSQL Workgroup Engine.
        Notes:
        • The program menu path may differ for different versions of Sage 300.
        • If rebooting the workstation does not help or the Pervasive preload does not automatically start up, but restarting or starting Pervasive preload helps, put the Start PSQL Workgroup Engine shortcut into the Startup menu.
  4. If using a terminal or Citrix server, verify that the Pervasive workgroup service is set to log on as a domain admin and that the password has not recently changed.
  5. Verify that there is no other program installed that also uses Pervasive/Actian like Sage 50 U.S. Edition or Accpac.
  6. Disable antivirus on the affected machine as a test and set antivirus exclusions as necessary.
  7. Verify permissions on the file server and local workstations.
  8. If the issue continues:
    • For issues only affecting one workstation, uninstall Pervasive/Actian from the affected workstation
    • For issues affecting all computers, uninstall Pervasive/Actian from the server.
  9. If restarting Pervasive/Actian services at the file server did not help, attempt to reboot the file server.
  10. Reinstall Pervasive/Actian on the server or workstation.


[BCB:156:Chat 300 CRE US:ECB]

Steps to duplicate
Related Solutions

What Sage 300 Construction and Real Estate and Sage Estimating files and folders should I exclude from my antivirus software scan?
Sage 300 Construction and Real Estate and Sage Estimating Required Windows Permissions
How do I add Domain Administrator credentials to Pervasive/Actian services
Can I use Sage 300 Construction and Real Estate software on a wireless network?
Error: "Data folder open validation error: I/O Error. Pervasive/Actian status code 94. The application encountered a permission error. Data files require user and system permissions."
Error: "I/O Error. Pervasive status code 170." (only domain administrator works)
Can I install Sage 300 Construction and Real Estate on the same machine as Peachtree (Sage 50—U.S.Edition)?