How do I Uninstall Pervasive/Actian/Zen?
Description
Cause

There are several reasons why the Pervasive/Actian/Zen PSQL software installation may need to be completely removed from the system:

  • Virus scanning software falsely identifies a file as malicious and deletes it
  • Other security software may also falsely quarantine files
  • Power surges or disk problems can corrupt program files
  • Windows updates may overwrite files or otherwise interfere with program function
Resolution
[BCB:2:Database warning:ECB]


  1. Make sure all users are out of Sage if you are uninstalling the Pervasive/Actian database engine on the server.
  2. Go to Programs and Features.
  3. Select the engine:
    • Actian Zen v15 Enterprise Server SP2
    • Actian PSQL [version] for 300CRE v16.1 to 24.1
    • Pervasive PSQL [version] for 300CRE v15.1 and older
  4. Right-click and select Uninstall.
  5. Delete or rename these folders if they exist:
    • For 300CRE v16.1 and newer
      • C:\ProgramData\Actian
      • C:\Program Files (x86)\Actian
      • C:\Program Files\Actian)
    • For 300CRE v15.1 or older
      • C:\ProgramData\Pervasive Software
      • C:\Program Files (x86)\Pervasive Software
      • C:\Program Files\Pervasive Software)
  6. Go to Windows Run or Search.
  7. Type regedit in the box and press Enter.
  8. If the following keys exist, rename them:
    • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Pervasive Software
    • HKEY_LOCAL_MACHINE\SOFTWARE\Pervasive Software
    • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Actian
    • HKEY_LOCAL_MACHINE\SOFTWARE\Actian

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Steps to duplicate
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