Error: "Data folder open validation error... Pervasive/Actian status code 94..."
Description
Cause
  • Incorrect permissions for one or more company data folders
  • Firewall is blocking Pervasive/Actian
Resolution

[BCB:3:Network warning:ECB]

Ensure the user has Full Control of the data share

Ensure that the user group for this user has Full Control permissions for the company data folder's Sharing and Security tab. Verify SYSTEM and Users, Domain Users, or Authenticated Users groups have Full ControlSee information about recommended permissions and Pervasive.SQL/Actian services log on as a Domain Administrator.

Verify firewall settings

Allow Pervasive/Actian service through Public and Private networks in Windows Firewall settings.

Run the Sage System Verifier

  1. Search for the Sage System Verifier and Run as Administrator. This allows the application to change the Firewalls as needed.
  2. Test launching Sage.

Replace the client db engine with the server version

If the problem persists after verifying the folder and user permissions, install the server version of the Actian database engine.

 




[BCB:156:Chat 300 CRE US:ECB]

 

Steps to duplicate
Related Solutions

Error: "Pervasive Status Code 94". (Troubleshooting)