Error: "Data folder open validation error: I/O Error. Pervasive/Actian status code 94. The application encountered a permission error. Data files require user and system permissions."
Description
Cause
  • Permissions are not set correctly for the company data folder(s) location
  • On VM, a secondary disk drive is used (other than c:). Permissions on folder Share and Security are set as required for Sage requirements.
  • Firewall blocking Pervasive/Actian
  • If permissions are correct and/or the user is logging in with Domain Admin credentials and they are still experiencing the issue, install the server version of the Actian database engine.
Resolution
[BCB:3:Network warning:ECB]

Option I: Ensure user has Full Control of the data share

  • Ensure that the correct users group this user belongs to has full control in both the Sharing and the Security tabs for the shared location that contains the company data folder(s). Verify both SYSTEM and Users, Domain Users, or Authenticated Users groups have Full Control.
  • On VM, with secondary drive. Have Administrator create a new Disk Drive. Create Sage Data folder share. Apply all permissions. Remove defective VM drive.

Option II: If permissions are set correctly, on Windows 10 Machines:

  • Search for the Sage System Verifier and Run as Administrator. This allows the application to make changes to the Firewalls as needed
  • Run the Verifier.
  • Try Logging on

Notes:

  • For assistance contact your Network Administrator.
  • If your system administrator prefers to use security groups other than the Everyone group, ensure that the SYSTEM account also has full control.
    • This error may be resolved by changing the Pervasive.SQL/Actian services to log on as a Domain Administrator. Please see KB Article ID 22105 for instructions.
  • Refer to the "Related Resources section below for an article outlining all permission requirements.
  • Make sure Pervasive/Actian service is allowed through both Public and Private network in Windows Firewall settings

Option III: Replace the client db engine with the server version.

  • See Related Resources for manual installation of Actian PSQL version 12.

DocLink: Sage 300 Construction and Real Estate and Sage Estimating Required Windows Permissions
DocLink: Error: "Pervasive Status Code 94". (Troubleshooting)
DocLink: How do I add Domain Administrator credentials to Pervasive/Actian services
DocLink: How do I add inbound/outbound port rules for Pervasive/Actian to the Windows Firewall?
DocLink: How do I manually install Actian PSQL version 12 Engine?

[BCB:156:Chat 300 CRE US:ECB]

Steps to duplicate
Related Solutions