The encryption key is invalid. See your system administrator.
Description

Cause

After installing Sage 100 2018.7 (6.00.7.0), and NOT going through the Conversion prior to printing a Library Master report. If another module is accessed prior to Library Master, the conversion prompt will appear as normal and this will not occur. This is related to Library Master now using the PII encryption and the logic checks the G/L module. This scenario does NOT occur in 2019.0 and higher. Defect # 110946 (v6.00.8.0 target)

After clean install of Sage 100 2019.1, launch Administrative Tools window. Go into Company Maint and convert data plus setup a new company with a copy of ABC. Setup a new Role with rights to everything and one user. Access System Configuration, FROM Administrative Tools and get "The encryption key is invalid. See your system administrator." Defect # 110950 (v6.00.8.0 target)

[Clarification: if you do NOT want to get the error open Library Master from a user login and NOT from the Administrator login after cloning ABC and creating a role/user in 2019.1]

Copying MAS_XXX (XXX=Company Code) data into the MAS90 folder of Sage 100 2018 installation.

Installing Sage 2018 in the same location as any prior installation and not removing the MAS90 folder prior to the installation.

If this message is received in the Visual Integrator application module, it may be because the General Ledger has not been set up yet.

Resolution
[BCB:1:Backup warning:ECB]


Go to Library Master, Main, select the company code or all companies and Convert. #110946

Remove the MAS_XXX folder that was copied into the Sage 100 2018 Mas90 directory.

  • Do NOT copy only MAS_XXX data under the MAS90 directory as done in 2017 and prior versions. Due to the encryption in version 2018, this will not work. Must also copy MAS_System folder when attempting to bring data into version 2018.

Uninstall the Sage 100 2018, remove the MAS90 folder and anything in it prior to reinstall.

  • Do NOT install version 2018 over an existing MAS90 directory from a prior installation.

If this message is received in the Visual Integrator application module, it may be because the General Ledger has not been set up yet in any company.

  • Set up the General Ledger module. In Sage 100, go to General Ledger, Setup menu, General Ledger Options.

DocLink: How to copy data from Sage 100 2018 and higher to a different installation for review by a trusted third party


Steps to duplicate
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