Files are being locked by third party programs (Sage Paperless Construction, TimberScan, MyAssistant, etc)
Description
Cause
This was determined to be caused by the ODBC tssimba file.
This has been reported in the following versions:
  • 17.1 with Sage Paperless Construction and MyAssistant
  • 18.1 and 18.2.1 with third party programs that utilize ODBC
Resolution

Note: Third-party developers should add the following to their connection string that they use when connecting with Sage 300 CRE. This will prevent their ODBC connection from leaving files locked open: KeepFilesOpen=0

Option 1:

Upgrade to Sage 300 Construction and Real Estate version 18.2.2 or newer:

  1. Make sure all users are out of Sage 300CRE and related programs.
  2. Stop the Sage Replicator (if using). See article ID 86272 DocLink: How to stop Mobile Projects Replicator (SQL Replicator)
  3. Download and install Sage 300 Construction and Real Estate 18.2.2. See article ID 90672 Download Sage 300 Construction and Real Estate 18.2 Accounting
  4. Restart Replicator (if using).
  5. Apply update from third party program.

Known third party versions required for version 18.2:

Notes:

  • If you are version 18.1 or 18.2.1 and are unable to perform the required updates at this time, continue to use the current workaround of stopping the third party services/programs.
  • If you are on version 17.1 and are unable to update to 18.2.2 or newer at this time, upgrade to version 17.1 Rev 8 and apply the 17.1.8 fix.

Option 2 (version 17.1):

Important note: This fix is only compatible with version 17.1 Rev 8

Follow these steps on the server and workstations:

  1. Make sure all users are out of Sage 300 CRE and related programs (Sage Paperless Construction, My Assistant, etc - and stop services).
  2. Stop the Sage Replicator (if using).
  3. Download and install Sage 300 Construction and Real Estate 17.1 Rev 8 from article 84956 (login required): Download Sage 300 Construction and Real Estate 17.1 Rev 8 Accounting
  4. Download the 17_1_8_odbc_hotfix_1.zip in the Attachments section below and unzip to extract the new tsSimba.dll.
  5. Browse to C:\Program Files (x86)\Timberline Office\Shared\.
  6. Rename the existing tsSimba.dll (ie orig_tssimba.dll).
  7. Copy the new tsSimba.dll from step 4, into the Shared folder.
  8. After all machines have been updated, restart Replicator (if using).
  9. Apply the update from the third party program.

Known third party versions required for version 17.1:

DocLink: How do I use the Pervasive Software Monitor Utility (PMU/PSMU) to unlock a file on a server that uses a Windows operating system?
DocLink: Sage Paperless Construction: How do I stop or start the Paperless services?
Attachment: 204_20230425125449_18.2.1odbchotfix1.zip
Attachment: 348_20230425125449_17_1_8_odbc_hotfix_1.zip

[BCB:156:Chat 300 CRE US:ECB]
Defect ID
542016, 541950
Steps to duplicate
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