Files are being locked by third-party programs (Sage Paperless Construction, TimberScan, MyAssistant, etc.)
Description
Cause
This was determined to be caused by the ODBC tssimba file.
This has been reported in the following versions:
  • 17.1 with Sage Paperless Construction and MyAssistant
  • 18.1 and 18.2.1 with third-party programs that use ODBC
Resolution

Note: Third-party developers should add the following to their connection string that they use when connecting with Sage 300 CRE. This will prevent their ODBC connection from leaving files locked open: KeepFilesOpen=0

Upgrade to the latest version of Sage 300 Construction and Real Estate:

  1. Make sure all users are out of Sage 300CRE and related programs.
  2. Stop the Sage Replicator (if using). See How to stop Mobile Projects Replicator (SQL Replicator)
  3. Download and install the latest version of Sage 300 CRE.
  4. Restart Replicator (if using).
  5. Apply update from third-party program.


[BCB:156:Chat 300 CRE US:ECB]
Steps to duplicate
Related Solutions

How do I use the Pervasive Software Monitor Utility (PMU/PSMU) to unlock a file on a server that uses a Windows operating system?