General Ledger has an incorrect Current Period End date and calendar (calendar changed back to a prior period or prior years)
Description
Cause

A user went into Setup Central and clicked through a combination of steps in the General Ledger section, triggering it to update the General Ledger calendar record with the Period end and Fiscal year end dates originally used in Setup Central when the company was created.

Example:

  • The Current period is 5/31/2022. A user goes into Setup Central and clicks through some of the General Ledger steps. After which, the Current period (Period ending date in the Fiscal settings) now shows 12/31/2016 instead, which was when the company was originally established in Setup Central.

The Log Viewer logs an entry for GL Generate Accounts when this occurs.

Resolution

This cause for this issue is fixed in version 24.1 of Sage 300 Construction and Real Estate.

IMPORTANT: Start with master article Double exclamation marks (!!) appear on the Current Ledger or Year-to-date Ledger in General Ledger (MASTER ARTICLE) before proceeding with this one.

PART 1: Verify what shows for your current period (Period End date)

The Period End date can be verified in multiple ways. Some options are as follows:

Option 1: In the Open/Close Posting Period window

  1. In General Ledger, select Tasks, Open/Close Posting Period.
  2. Depending on your Fiscal Settings, you may be prompted to select a GL Prefix, or the list of Prefixes will be displayed with their current Period End date, or the window with the check boxes for the period end dates will appear, where the first period in the top-left column is the current period.
  3. Click Cancel after you have obtained the current Period End date.

Option 2: The Prefix List reports, if you are using prefixes in your GL account format and the fiscal settings are at a prefix level

  1. In General Ledger, select Reports, Lists, Prefix (A, B, or C, depending on your fiscal level). If you are unsure which level your fiscal settings are established, start with the Prefix A list report which will show which level the Fiscal Settings are set.
  2. Print Preview the report.
  3. Note the Period End date, or if the Fiscal Settings are at a different level. If the Fiscal Settings are a different level, run the Prefix B or Prefix C list as applicable.

Option 3: Fiscal Settings

If your Fiscal Settings are at the company data folder level:

  1. In General Ledger, select File, Company Settings, GL Settings, Calendar/Fiscal Settings.
    • Note: If the Calendar/Fiscal Settings button is grayed out, this means that your Fiscal Settings are established at a prefix level.
  2. Make note of the Period Ending date.
  3. Click Cancel to exit the Calendar/Fiscal Settings window.
  4. Click Cancel to exit the GL Settings window.

If your Fiscal Settings are at a prefix level:

  1. In General Ledger, select Setup, Prefix/Base.
  2. Your options from the Prefix/Base menu depend upon how many prefix sections are used and what the sections are named. The first one on the list will be for Prefix A. Whether you have a second (Prefix B) and third (Prefix C) option before Base Accounts depends if those additional sections are used. Select the Prefix option where the fiscal settings are established.
  3. Use the List button to select the prefix, click OK then press the ENTER key twice so that the cursor focus is in the General Information tab section.
  4. Click the Fiscal Settings button.
    • Note: If the Fiscal Settings button is grayed out, either the cursor focus is not in the General Information tab area (step 3) or this is not the prefix level where the Fiscal Settings are established.
  5. Make note of the Period Ending date.
  6. Click Cancel to exit the Fiscal Settings window.
  7. Click Cancel to exit the prefix edit.
  8. Click Close to exit the prefix setup window.

PART 2: After verifying the current period (Period End date)

If the Period End date shows it went back to a prior date, or did not advance as the Close Current Period or Close Fiscal Year journal indicates that it did:

  1. Stop processing for this company folder. Do not close periods in an attempt to bring it current.
  2. Contact Sage 300 Construction and Real Estate Customer Support for General Ledger to have your issue escalated.
  3. Instruct your users to not use Setup Central on company folders where setup has been completed and processing started.

 

If this is not your issue, refer to Double exclamation marks (!!) appear on the Current Ledger or Year-to-date Ledger in General Ledger (MASTER ARTICLE) for other possible causes and solutions.



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