Error: "An Error Occurred. Close and then re-open Sage Desktop" (on workstation)
Description

Error occurs before the Sage System Verifier runs. The Event Viewer lists a Buffer Overflow Exception (BEX) for TsVersionChecker.dll.

Full error message

Faulting application name: ap.exe, version:16.1.8.16, time stamp: 0x5a0b81d3 
Faulting module name: tsVersionChecker.dll, version: 16.1.8.16, time stamp: 0x5a0b7a9c 
Exception code: 0xc0000005 
Fault offset: 0x000070cb 
Faulting process id: 0x1300 
Faulting application start time: 0x01d4b4d2cc7a217f 
Faulting application path: C:\Program Files (x86)\Timberline Office\Shared\ap.exe 
Faulting module path: C:\Program Files (x86)\Timberline Office\Shared\tsVersionChecker.dll 
Report Id: 0a3c2390-20c6-11e9-80cc-00155d0e0e16 
Faulting package full name: 
Faulting package-relative application ID:

Cause

Missing or corrupt copy of TsVersionChecker.DLL on the new client installation.

Resolution
  1. Log on to a workstation that doesn't receive the error.
  2. Browse to the C:\Program Files (x86)\Timberline Office\Shared\ folder.
  3. Copy the TsVersionChecker.dll and paste it to the same path on the workstation with the error.
  4. Try to open Sage again.
  5. If the issue continues, troubleshoot other possible causes.

 

 

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Steps to duplicate
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