The post and interface settings changed in Accounts Receivable or other applications
Description

In Sage 300 Construction and Real Estate cases have been reported where the Activate Interface setting to Contracts was deactivated in Accounts Receivable, File, Company Settings, AR Settings, Post & Interface Settings, and the change and/or access to the settings is not present in the system log. This issue has been reported in both 17 and 18 versions. This same issue may occur in other applications as well.

Symptoms of this issue include but are not limited to: 

  • In Accounts Receivable, File, Company Settings, AR Settings, Post & Interface Settings, the Activate interface settings to Contracts and/or other applications is turned off
  • The previous work completed showing in Billing, Contract Based invoices is incorrect
  • The work billed, cash receipts and/or adjustments to date in Contracts are incorrect
  • Contract related transactions that exist in Accounts Receivable are missing in Contracts
  • The Contracts column is missing from the distribution grid in the Accounts Receivable, Enter Invoices task when using a view that is set to include Contract information
  • Contract related entries are not posting from AR to Contracts - the entries in AR show with distributions to contracts, however the associated batch and related entries in not found in the Contracts application
  • The Contracts Recap is missing from the Billing and/or Accounts Receivables Posting journals
  • In any application, File, Company Settings, Application Settings, Post & Interface Settings, the Activate Interface setting to one or more applications is turned off, and was not manually changed by a user
  • The Recap associated with one or more interfacing applications in missing from Posting journals
     

Note: There are other possible causes associated with entries not posting to interfacing applications. See the Resolution section for more information.

 

Changes included in Sage 300 Construction and Real Estate version 18.3.1 that may prevent this issue from occurring. We are however still seeing this issue occur in version 18.4.1 and above and continue to research the cause.

Cause

The post and interface settings were changed and are not reported in the system log.

We are currently researching the potential cause and resolution to prevent this issue.

Resolution

Check your interface setings in Accounts Receivable:

  • In Accounts Receivable select File, Company settings, AR Settings. Click on the Post & Interface Settings button. Verify that the desired interfaces are activated and set to create entries to the interfacing applications.

If your interface setting are still active and set to create entries, use the following articles to find a possible cause and resolution of your issue:

If your interface settings are not active, please contact Sage 300 Construction and Real Estate support if you suspect you have been affected by this issue. The analyst answering your call will begin triaging the issue and escalate your case to a Senior Product specialist for assistance. In order to identify the cause of this issue we are asking customers experiencing this issue to load a file that will enable additional logging to track when post and interface settings have changed.

Triage Steps may include:

  • Review of all posting journals to determine what entries may or may not have flowed through to all of the appropriate applications
  • Review of the System log in Tools, Log Viewer to determine if a user may have accessed the settings that may have turned off the interface
  • Enabling additional logging capabilities to help identify what is causing the interface settings to disable.

Note: A full reconciliation may be necessary

Steps to duplicate
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