Sage Paperless Construction: Permissions issues after install or upgrading
Description

In Sage Paperless I receive the error: 

 Program: PEAppServer 
Error: System.Exception 
Description: 
Could not Create DAL on Application Server. Check the Application Server Error Log for Details. 

   
 In Sage Paperless when I try to save, index or push to queue with a document, I receive: 

 An error has occurred. 
PEViewer.Codecs. 
Error saving PVD file. 
Access to the path \\<servername>\<sharename>\Documents\<folder>\<docID> is denied

   

 This may also present as an inability to load vaults or an inability to load F4 lookup screens. 
   

 When trying to access images you may receive "This file no longer exists" or "The selected document no longer exists" when selecting any document. 

 Attachment sync may fail with error: "Access to the path \\<servername>\<sharename>\... is denied."

Cause

Permissions indicated in the setup guide are required for the account that is used to run the Sage Paperless Construction services.

Resolution

Antivirus applications may quarantine or delete files downloaded as part of the upgrade. Check Antivirus logs if permission issues persist while installing or deploying update. In some cases you may need to suspend the antivirus protection while preforming an install or create exclusions to files being quarantined. Work with your IT or Network Administrator to allow the installation to adjust security settings to allow the process to complete.

  1. Launch the SPC Dashboard and confirm which Windows account is being used on the App service tab, Poll service tab and Web Service tab.
  2. Modify Windows Share and NTFS permissions as needed to confirm that the Windows account(s) being used for these services have full control for the following locations and shares:
    • Sage Paperless Construction server:
      • Sage Paperless Construction folder and share (path will vary depending on where this was set up - path can be determined in the SPC Dashboard)
        Note: If you are logged on to the server using a network account that is different then the one used when the SPC server was initially installed and you will use this account to deploy Sage Paperless Construction be sure to add the account this Share with Full Control.
      • Documents directory - this is specified on the General tab of the Vault in SPC Administration, Vaults and it does not have to reside under the same location as the server application folder.
      • Windows temp folder
    • Sage 300 Construction and Real Estate server, this may be on the same server as Sage Paperless construction or on a different server in the domain:
      • C:\ProgramData\Sage\Timberline Office folder and related share
      • Data location folder and related share (this path will vary depending on where the accounting data is stored)
    • Sage 100 Contractor server:
      • Data location folder and related share (generally the Sage100Con folder/share)

For a deeper look at the windows permissiosn refer to the article DocLink: Sage Paperless Construction: Required Windows Permissions and review the Sage Paperless Construction Setup Guide, both linked below.

DocLink: Sage Paperless Construction: Required Windows Permissions.
DocLink: Sage Paperless Construction: Setup Guide

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