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Error: "New periods could not be assigned."

Created on  | Last modified on 

Summary

The error occurs when attempting to close a year in Sage 50 Accounting.

Description

  • Unable to complete the Year-End Wizard
  • Can't assign new periods during the Year-End Wizard

Cause

The year-end process is encountering a problem assigning new period numbers to each transaction in the system.

Resolution

CAUTION: Use caution when working with the below product functionality. Always create a backup of your data before proceeding with advanced solutions. If necessary, seek the assistance of a qualified Sage business partner, network administrator, or Sage customer support analyst.

1. Expendable file cleanup

  1. Restore Backup before running the Year-End Wizard.
  2. Make a note of the company directory in the Directory line by going to Maintain, Company Information.
  3. Close Sage 50 and Company, and then browse to the specific company directory noted in step 2.
  4. Perform an expendable file cleanup on the company. See Create a clean data folder and expendable file cleanup.
  5. Open Sage 50 and company. Then run the Year-End Wizard, making sure to select the Data Verification option to run.

2. Chart of Accounts / Journal Synchronization

See How do I run the Chart of Accounts Journal Synchronization test?

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