Summary
Steps to resolve errors or crashes when running reports.
Cause
Errors caused by incorrect printer information include:
- Error: “Invalid printer specified”
- Error 1904. Module C:\Program Files (x86)\SAP BusinessObjects\Crystal Reports for .NET Framework 4.0\Common\SAP BusinessObjects Enterprise XI 4.0\win32_x86\commonobjmodel.dll failed to register
- This field name is not known
- Error: "Error occurred while generating report - please contact your system administrator. Details: Error executing the report <report name>
On the update installation of Sage Fixed Asset Premier, Network, or Single User products to a local workstation, the product-specific configuration .XML file finds invalid, out of date, or no printer information.
Resolution
Note:
- Reports use the printer, even when sending to a window.
- These steps aren’t intended for a shared environment where other users might be using the same client. Example: Terminal Server, Citrix, Remote Desktop Services. See Error: "Invalid Printer Specified" on Citrix or Terminal Server.
Option 1: Select the Correct printer
- Go to: File, Print Setup, select the desired printer and click OK.
Note: If errors occur on the 199a Report use the Microsoft XPS Document Writer as the printer. - Run a report to see if the error still occurs.
- Verify the Printer information:
- In Windows Explorer, browse to C:\Program Files (x86)\Sage Fixed Assets\Lite Depreciation or Depreciation or Depreciation Network or Premier Depreciation\
- Right-click FASSTEP.XML (Lite Depreciation), FASACCT.XML (Depreciation or Depreciation Network) or ASSTACCT.XML (Premier Depreciation), select Edit.
- Check the tag populated with your printer information
- If the tag is blank, contains a printer other than the selected or the XML file is blank: Delete the XML file, open the program, and repeat Step 1
- If the tag is populated correctly and the issue still occurs: Delete the XML file, open the program, and repeat Step 1
- If after deleting the XML file and selecting a printer the issue still occurs, see Option 2.
Option 2: Uninstall Sage Fixed Assets
- Uninstall all Sage Fixed Assets clients on the machine where the error has occurred. This can include:
- All Sage Fixed Assets Clients (Depreciation, Tracking, Planning)
- All FAS clients (Asset Accounting, Inventory, CIP)
- Crystal Reports XI Release 2 for Sage
- SAP Crystal Reports 2011 for Sage
- Browse to C:\Program Files (x86).
- Delete or Rename SAP BusinessObjects folder.
Note: If there are other versions of Crystal installed on the system, uninstall them before changing the Business Objects folder. Crystal must install from the oldest to the newest version to prevent Crystal conflicts. - Install Sage Fixed Assets Depreciation (and all other needed clients), repeat the steps in Option 1.
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