Summary
WIP items generated a "Contract unknown" message in Sage 300 CRE Billing.
Cause
The contract link is incorrect
- The contract item isn’t linked to a job in the Contracts application
- The contract link is incomplete
- The Job is attached to more than one Contract by mistake
- The transaction includes an Extra, but the contract item isn’t linked to an Extra
- More than one contract item is linked to the same job and extra but not linked to the cost code
- The contract contains more than one contract item, but the items aren’t linked to cost codes
- The Pay ID on the Rate table isn’t the same Pay ID on the transaction from Payroll
Resolution
Link the contract item to the Work-in-progress job and cost code transaction. On the Billing Generate WIP journal, note the rejected job, extra, or cost code. Follow the steps below based on the rejection. After you've made corrections to the contract item and the links, go to Billing, Tasks, Work-In-Progress, Generate to process the rejected records.
Confirm the job is linked to only one contract
- Go to Contracts, Reports, Lists, Contract / Job Link.
- Select CN Contract (active) and then click OK.
- Click Condition, Add.
- In the Field list, select Job.
- In the Operator section, select Equal to.
- In the Value box, type the Job ID you want to review.
- Click OK twice.
- Click Start.
If the job or extra isn’t linked to a contract
- In Contracts, select File, Open Contract.
- Select the active contract to link.
- Select the contract item.
- On the General tab for each contract item, verify you select the correct Job for the Link.
- If the contract item Status isn’t Approved and the item isn’t linked to the right job, select the correct job. Click the list button to display a list of available jobs.
Note: Only jobs you’re authorized to view that have a billing type of Use Contracts appear in the list. - If the contract item Status is Approved, you can’t change the job and extra links. See the Contracts help topic "About unapproving contract items" for steps to unapprove an item and link it correctly. Go to Contracts, Help, Help Topics and in the Index tab type "approve".
Note: If you’re using extras and linking more than one contract item to the same extra, also link cost codes to each item. If you don't, you’ll receive the Contract unknown error. You can select group cost codes for each item and it will link all the individual cost codes within the group.
- If the contract item Status isn’t Approved and the item isn’t linked to the right job, select the correct job. Click the list button to display a list of available jobs.
Link the contract item to a cost code
- In Contracts, select File, Open Contract.
- Select the active contract to link.
- From the View menu, select Job Links.
- Select the contract item to link.
- From the Edit menu, select Link.
- Enter the Cost Code. Click the list button to display a list of available cost codes.
- Click OK.
Cost Code linking information
- You can't link an individual cost code to more than one contract item
- You can link a contract item to more than one cost code within the job by repeating the steps above for each cost code
- You can unlink a cost code even after you unapprove the contract item
- If you enter a standard cost code that doesn’t exist for the job, it’s automatically created in the Job Cost master file
- If you enter a group cost code, all the individual cost codes within the group are linked to the item