Error: "Report file C:\ProgramData\Sage Software\Cache\MAS 200\report name.rpt is not found or does not exist. Load Report Fails"

Summary

Error: "Report file C:\ProgramData\Sage Software\Cache\MAS 200\ .rpt is not found or does not exist. Load Report Fails" when printing from Sage 100" The full error message lists each directory on a separate line. Note : "C:\ProgramData" is a hidden system folder. Not all users have enabled the option to display it.

Cause

  • Environmental Variable is not set correctly.
  • The Crystal Report form or report may have been customized or become corrupted.
  • Prerequsite(s) are not installed

Resolution

CAUTION: This solution needs advanced Operating System knowledge. Consult your system administrator for help. Sage isn't liable for issues caused by improper changes to the Windows Registry. Always back up your data before applying advanced solutions.
CAUTION: Sage support can't assist with third-party products, hardware, report customizations, or state and federal tax questions. Refer to our Scope of Support for more info. Contact your Sage business partner, network administrator, or accountant for assistance.

 

  • Reinstall workstation setup using Autorun.exe located under ...\MAS90\WkSetup\ folder
  • If you're running Sage 100 through Remote Desktop\Terminal Server Client, contact your Network Administration and have them verify the following:
    • If "Use temporary folders per session" is enabled for Remote Desktop Sessions on the Remote Desktop Server, make sure the Temporary folder are being created
    • Delete files\folder from user(s) %USERPROFILE%\Appdata\Local\Temp\ folder
    • Disable "Use temporary folders per session" for Remote Desktop Sessions

    Configure Temporary Folders for RD Session Host Server

Verify TEMP folder exist

  1. Exit Administrative Command Prompt
  2. To change TEMP path back to Windows Default (C:\Users\Username\Appdata\Local\Temp) follow the steps below
    1. Open a Administrative Command Prompt
    2. Type: Set TEMP=%USERPROFILE%\AppData\Local\Temp
    3. Press Enter
  3. If path does not exist move to Step 6 or manually create path. If it does exist contact Sage Support for more assistance
  4. Verify the path exist.
  5. Type: Set TEMP
  6. Enter: CMD
  7. From the Windows Desktop, select Start, Run
    Note: With some operating systems, select Start, Search programs and files

If you are still receiving the error, try the step below

  1. From the Windows Desktop, select Start, Run
    • Note: With some operating systems, select Start, Search programs and files
  2. Enter: CompMgmt.msc
  3. Press Enter or select OK to open the System Properties
  4. Select Advanced tab
  5. Click the Environmental Variables button to open the Environmental Variables window
  6. In the User variable for section, click the TEMP variable
  7. Verify the path in the Value colunm for TEMP variable is correct and that the user has Read/Write access to that folder
    • Note: The default value is exactly this: %USERPROFILE%\AppData\Local\Temp
    • Note: Verify by accessing the location via Windows Explorer and checking the permissions. If you don't know the location, do the following:
      1. From the Windows Desktop, select Start, Run
        • Note: With some operating systems, select Start, Search programs and files
      2. Enter CMD
      3. Press Enter or select OK to open a Command Prompt window
      4. Enter the following command and press the Enter key: echo %userprofile%
      5. The result will display where the User Profile is stored, such as C:\Users\
      6. The location will therefore be C:\Users\\AppData\Local\Temp
  8. If the path in the Value column is incorrect, change it back to the default value.
  9. Click OK to close the Environmental Variables window
  10. Click OK to close the System Properties window
  11. Reboot the workstation for changes to take affect.

Note: it is also possible that this error is occurring because the Crystal Report form or report may have been customized or become corrupted. One way to test this is to create a new Report Setting or Form Code. Sage 100 Customer Support cannot assist in creating or modifying custom Crystal Reports, nor with troubleshooting errors encountered with custom Crystal Reports.

It is also possible that Antvirus program or Malware protection is blocking access to the .RPT file or creation of temporary files. See Related Resources for Antivirus Exclusions for Sage 100.

If other solutions do not work, and Knowledgebase articles have been checked regarding APPDATA, TEMP settings, environmental variables, etc. and the error also displays error that Crystal Reports report engine "threw an exception" (in addition to Cache error message):

It is possible that another program installed a different version of Crystal Reports runtime or that it has become corrupted. if there is still conflict after checking settings and uninstalling/reinstalling Sage 100 workstation, it may be possible for Sage 100 2018/2019 to manually install from Related Resource "Unable to cast COM object of type". Install SAP Crystal Report SP21+ x32 on the workstation:

http://downloads.businessobjects.com/akdlm/crnetruntime/clickonce/CRRuntime_32bit_13_0_22.msi

DocLink: How to exclude Sage 100 from anti-virus (antivirus) Real-time scans


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Solution Properties

Solution ID
224924250051884
Last Modified Date
Fri Dec 16 17:03:40 UTC 2022
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