Skip to content
logo Knowledgebase

Sage 100 Prerequisites

Created on  | Last modified on 

Summary

Before you install Sage 100, certain other programs must be present.

Description


Cause


Resolution

CAUTION: This solution requires advanced knowledge of your computer's operating system. Contact your system administrator for assistance. Modifying your Windows Registry incorrectly can severely affect system operations. Sage is not responsible for operation issues caused by incorrectly modifying your Windows Registry. Always create a backup of your data before proceeding with advanced solutions. 

Note: Prerequisites are installed when the installation is ran through the Autorun.exe application. You can also manually install prequisites from the Prerequisites folder under the installation image/CD (for Sage 100 workstation clients its located under the ...mas90\wksetup\ folder)


Sage 100 2013 (retired)

  • .NET Framework 3.5 SP1 (See the DocLinks below.)
  • .NET Framework 4.0 (See the DocLinks below.)
  • Microsoft Visual C++ 2005 Runtime Libraries (Prerequisites\VC 2005 SP1 Redist\vcredist_x86.exe), (Prerequisites\VCRedist\vcredist_x86.exe)
  • Microsoft Visual C++ 2010 Runtime Libraries (Prerequisites\vcredist_x86.exe)

Sage 100 2014 - 2016

  • .NET Framework 3.5 SP1 (See the DocLinks below.)
  • .NET Framework 4.0 (See the DocLinks below.)
  • Microsoft Visual C++ 2005 Runtime Libraries (Prerequisites\VC 2005 SP1 Redist\vcredist_x86.exe), (Prerequisites\VCRedist\vcredist_x86.exe)
  • Microsoft Visual C++ 2010 Runtime Libraries (Prerequisites\VC2010\vcredist_x86.exe)
  • Microsoft Visual Studio 2010 for Office Runtime (Prerequisites\VSTO Runtime\vstor40_x64.exe (vstor40_x86.exe, for Windows 32-bit OS)
  • Microsoft SQL Server Compact 3.5 SP2 (Prerequisites\MsSqlServerCE\SSCERuntime_x86-ENU.msi)

Sage 100 2017

  • .NET Framework 3.5 SP1 (See the DocLinks below.)
  • NET Framework 4.5.2 or higher (See the DocLinks below.)
  • Microsoft Visual C++ 2005 Runtime Libraries (Prerequisites\VC 2005 SP1 Redist\vcredist_x86.exe), (Prerequisites\VCRedist\vcredist_x86.exe)
  • Microsoft Visual C++ 2010 Runtime Libraries (Prerequisites\VC2010\vcredist_x86.exe)
  • Microsoft Visual Studio 2010 for Office Runtime (Prerequisites\VSTO Runtime\vstor40_x64.exe (vstor40_x86.exe, for Windows 32-bit OS)
  • Microsoft SQL Server Compact 3.5 SP2 (Prerequisites\MsSqlServerCE\SSCERuntime_x86-ENU.msi)

Sage 100 2018 (includes the same Prerequisites as Sage 100 2014 - 2016, plus the following)

  • .NET Framework 4.6 or higher (See the DocLinks below.)
  • Microsoft Visual C++ 2005 Runtime Libraries (Prerequisites\VC 2005 SP1 Redist\vcredist_x86.exe), (Prerequisites\VCRedist\vcredist_x86.exe)
  • Microsoft Visual C++ 2010 Runtime Libraries (Prerequisites\VC2010\vcredist_x86.exe)
  • Microsoft Visual Studio 2010 for Office Runtime (Prerequisites\VSTO Runtime\vstor40_x64.exe (vstor40_x86.exe, for Windows 32-bit OS)
  • Microsoft SQL Server Compact 3.5 SP2 (Prerequisites\MsSqlServerCE\SSCERuntime_x86-ENU.msi)

Sage 100 2019 - 2020 (includes the same Prerequisites as Sage 100 2018, plus the following)

  • .Microsoft Visual C++ 2017 Runtime Libraries (Prerequisites\VC2017\vcredist_x86.exe)

Sage 100 2021 (includes the same Prerequisites as Sage 100 2018, plus the following)

  • .Microsoft .NET framework 4.72 or higher (See the DocLinks below.)
  • Microsoft Edge Webview


DocLink: Installing Sage 100 ERP prerequisites displays Error: "Sage 100 ERP Server Error"
DocLink: How to install Sage 100 ERP client through Group Policy Management and Command Prompt (Silent Install)
DocLink: How do I install or enable Microsoft .NET Framework 3.5 on a Windows 8 or Windows Server 2012?

Chat with support