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Error: "An unknown error occurred connecting to the SMTP server..."

Created on  | Last modified on 

Description


Cause

  • Webmail account not configured to allow access to Sage
  • Email setup not correct in Sage when emailing with Outlook
  • Security software blocking
  • Using Recovery email rather than Google email under Personal info & privacy
  • Incorrect password for webmail

Resolution

Section 1: Configure the webmail account to allow emails from Sage


  1. Select Email Setup from the Maintain menu, or click Edit Email Setup button from the Company Maintenance section of the System navigation window.
  2. Click Use a webmail account, and then click the link Add account information
  3. Select the type of email service and enter the email address (Outlook.com, Gmail and Yahoo are mostly predefined) (If you select Other, you will also need to provide the SMTP server and the SMTP port), this information can be obtained from your Internet Service Provider
  4. After the email account is defined, use the Edit and Remove hyperlinks to make changes

Section 2: Alternate steps for Gmail configuration

  1. Open the transaction you want to email then click E-mail
  2. Enter the email address you wish to email the transaction to, if blank, and click Send
  3. This should open a new browser window for your default browser.
  4. Sign into your Gmail account if not already or just click your Gmail account
  5. Click Continue to Sage 50 US wants to access your Google Account
  6. Verify you can send emails from Sage using Gmail without the error

Section 3: SMTP is disabled in the Microsoft 365 admin center

  1. Log in to the Microsoft 365 admin center and go to Users, Active users.
  2. Select the user, and in the flyout that appears, select Mail.
  3. In the Email apps section, select Manage email apps.
  4. Place a checkmark in the Authenticated SMTP setting to enable.
  5. Click Save changes.
  6. Verify that you are able to email from Sage 50 now.

For more information visit https://docs.microsoft.com/en-us/exchange/clients-and-mobile-in-exchange-online/authenticated-client-smtp-submission

Section 4: Use MAPI-compliant email program instead of webmail

  1. Select Email Setup from the Maintain menu, or click Edit Email Setup button from the Company Maintenance section of the System navigation window.
  2. Select Use a default desktop email program box, and then click OK
  3. Verify you can email, if not you may also need to reset the default email program in the control panel, default programs, select the default you want (like Outlook in the list) and then click OK (these steps are computer specific)

Section 5: Antivirus / Firewall / Security software blocking the process

  1. Temporarily disable any antivirus/firewall or security software to see if it is blocking the email.
  2. Verify you can send emails from Sage using webmail without error.

Section 6: Confirm webmail password

  1. Confirm that the password for the webmail (Google, Yahoo) account is correct.

Section 7: Damaged Sage 50 E-mail Writer

  1. Close Sage.
  2. Enter WINDOWS + R keys, type Control, and then click OK.
  3. Select Devices and Printers.
  4. Right-click Sage 50 E-mail Writer v3, and then select Remove Device.
  5. Remove any other Peachtree E-mail Writer or Sage E-mail Writer.
  6. Select any available printer, and then select Print server properties.
  7. Select Drivers tab, Amyuni Document Converter 550, and then click Remove.
  8. Select Remove driver and driver package, and then click OK.
  9. Go back to Print Server Properties.
  10. Select Drivers tab, Amyuni Document Converter 300 or 500 (if present).
  11. Select Remove driver and driver package, and then click OK.
  12. Follow How to run Repair.
  13. Enter WINDOWS +R keys, type Control, and then click OK.
  14. Select Devices and Printers.
  15. Right-click Sage 50 E-mail Writer v3, and then select Printer properties.
  16. Select Ports tab, and then click Add Port button.
  17. Select Local Port, and then click New Port button.
  18. Enter PDF1 as the port name, and then click OK.
  19. Select Advanced tab.
  20. Select Enable advanced printing features box, and then click Apply.
  21. Select Print directly to the printer box, click Apply, and then Close.
  22. Reboot your computer.

Section 8: Damaged program

Completely reinstall. Follow How to manually remove the program for instructions.

Note: This document involves editing the registry and extensive navigation in Windows. Contact your Computer Professional for assistance if needed.

DocLink: Files to allow through firewall and antivirus