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Error: "loading configuration file...exit code -2"

Created on  | Last modified on 

Summary

How to resolve "Error loading configuration file...exit code -2" where tax forms do not open.

Description


Cause

  • Antivirus blocking the update
  • Corrupted tax forms
  • Damaged registry key

Resolution

CAUTION: This solution requires advanced knowledge of your computer's operating system. Contact your system administrator for assistance. Modifying your Windows Registry incorrectly can severely affect system operations. Sage is not responsible for operation issues caused by incorrectly modifying your Windows Registry. Always create a backup of your data before proceeding with advanced solutions. 


CAUTION: Sage Customer Support does not assist with issues related to third-party products or enhancements, hardware, report customizations, state or federal tax-related questions, or specific accounting questions. Please get in touch with your Sage business partner, network administrator, or accountant for assistance. Please refer to our Scope of Support document for details.


Section 1: Disable antivirus/firewall

  1. Disable your antivirus or Internet security software.
  2. Open the tax form.
  3. Verify the forms will update.
  4. If these steps solved the problem, follow Files to allow through firewall and antivirus. Otherwise skip to Section 2.

Section 2: Manually remove and reinstall the Payroll Tax Forms

  1. Press the Windows key + E to open the File Explorer.
  2. In the File Explorer browse to C:\Program Files (x86)\Common Files\Peach (or C:\Program Files\Common Files\Peach in 32-bit Windows).
  3. Rename the FormViewer folder. Note: It is not recommended to delete this folder as that could potentially cause the loss of custom Human Resources forms.
  4. In the File Explorer browse to C:\ProgramData and press Enter.
  5. Delete the Aatrix Software folder.
  6. In the File Explorer type %userprofile% and press Enter.
  7. Open the AppData folder and then open the Local folder. Delete the Aatrix Software folder
  8. Open the AppData folder and open Roaming folder Delete the Aatrix Software folder
  9. Open the AppData folder and then open Local then open the Temp folder. Delete the folder AatrixTemp and the file PAW.aef
  10. Download and run the update (Peach.exe) from https://partner.aatrix.com/sage-50-accounting/. Note: If you receive an error message that "Another version of this product is already installed," when running the Aatrix update, proceed to Section 3.
  11. Verify you can update and open the payroll tax forms
  12. If the error persists, proceed to Section 3

Section 3: Error: "Another version of this product is already installed" when installing Sage 50 Accounting Tax Forms

  1. Make a backup of the registry. See How do I back up or restore registry keys in the Windows Registry Editor? or consult your IT professional for help.
  2. In the registry editor, browse to HKEY_CLASSES_ROOT\Installer\Products
  3. Go to Edit and select Find.
  4. In the search field, type (or copy and paste) Sage 50 Accounting Tax Forms and click Find Next.
  5. When the search is complete, a yellow folder on the left side will be highlighted in gray with a value of 7A4FE1AB76BAB294C9D7A4EE345F3A6C. Delete that folder and close the registry editor
  6. Run the Peach.exe from https://partner.aatrix.com/sage-50-accounting/ again to install the Sage 50 Accounting Tax Forms.
  7. After the update is complete, verify the error no longer shows.

Related Solutions

Why am I prompted to install a tax form update after downloading and installing the most recent update manually?