The print screen disappears intermittently without printing or previewing

Summary

In Sage 100 2022 - 2024 64-bit, print screen disappears without printing or previewing a report. A program fix is available to resolve this issue.

Description

In Sage 100 2022-2024 64-bit, this resolves the issues where:

  • Print screen / task disappears or closes without printing or previewing report in Sage 100 64-bit.

Or

  • When printing via BOI in Sage 100 64-bit, errors like the following can occur: Error in File [Crystal Report file name]: Database Connection Error.

NOTES: 

  1. Run the installation on the Sage 100 Server and each workstation.
    • This requires Administrator permissions on the Sage 100 Server and workstations.
  2. Make sure all users are out of Sage 100 before installing this update.
  3. For Sage 100 Advanced:
    • Have all users exit Sage 100.
    • Close the Sage 100 Application server.
    • Close the Client Server ODBC Driver service or ODBC application running on the server.
  4. Reapply the update if you reinstall the Sage 100 Server or workstation.

Cause

Workstation running Windows 11 22H2 and higher

Resolution

A program fix is available for Sage 100 2022 - 2024 releases (any product update) 64-bit. 

Note: This issue doesn’t affect Sage 100 32-bit. If the issue with Crystal Reports preview disappearing occurs in 32-bit Sage 100, see article: Unable to preview Sage 100 Reports.

 

To apply the program fix:

  1. Download Sage 100 2022 - 2024 Program Fix ODBC Update
  2. See the PDF in the Attachments section of the above article for details.

 NOTE: Run the installation on the Sage 100 Server and each workstation and requires Administrator permissions on the Sage 100 Server and workstations 

 

 

Solution Properties

Solution ID
240627142310467
Last Modified Date
Thu Nov 06 17:20:43 UTC 2025
Views
0