Summary
"The record you requested has been deleted or you may not have security permissions to view it" and cannot view companies in CRM.
Description
In CRM 2024 R1 integrated with Sage 100, after adding company, when trying to view companies getting error message "The record you requested has been deleted or you may not have security permissions to view it" and cannot view companies in CRM.
Cause
Related to Sage 100 integration
Resolution
This error may occur if the option from CRM setup menu was chosen to "Integrate an existing Sage CRM 2024 R1 with Sage 100".
The error "record you requested" does not occur if you manually run the Sage 100 integration scripts by selecting the "Sage 100 xxxx Configuration.exe" file from the CRM install files. (i.e. Sage 100 2024 Configuration.exe).