ERROR: "An error occurred synchronizing with Remote Data Access."
Description
  • Error: "An error occurred synchronizing with Remote Data Access. This company is not synchronized and will close in one minute." 
  • Error: "The Company backup failed to upload to Remote Data Access"
  • Error: "The company must be closed in order to apply the latest changes from Remote Data Access. The company will automatically close in 1 minute."
  • Error: "Dynazip error 18: File user name.cax could not be opened for reading."
Cause
  • Invalid or incorrect files or folders in the company
  • Large form files
  • Slow or unstable Internet connection
  • Damaged data
  • Firewall
  • Expired Antivirus
Resolution

Irregularity in User Security or Company Info

  1. Go to Maintain > User > Set Up User Security.
  2. Verify that all users have a unique email address.
    • If there is a user who has an asterisk by their name, and they have the same email address as an existing user in the company: Add the user to the company and remove the email address, or assign a different email address
    • If the username with the asterisk is the same as another username in the user list: won't be able to be added to the company you're currently in. You would have to access the user list of the company where the other username is listed in and delete it from that company
  3. Save and Close.
  4. Go to Maintain > Company Information.
  5. Remove any special characters from the company name, such as ";"or "*" (try replacing "&" with "and").
  6. Share the company again.
    • If the error still occurs, go to Set Up User Security and delete all users except for the data owner. Share the company again, and if it shares successfully, go back to Set Up User Security and add the other users back.

When attempting to share the company after any of these troubleshooting steps: If the error occurs again, try again at least once or twice more, following the steps below. It's uncommon for it to fail on the first pass as it attempts to reconnect to the cloud, but then shares successfully after another pass is made.

  1. Click Close on the error message.
  2. If the program doesn’t close automatically and reopen to attempt sharing again: Mouse across the Sage 50 taskbar button on the bottom and close the Processing Collaboration window by clicking x. This will go back to a share pending state in Set Up User Security. If it doesn't go back to a share pending state, close the entire program. Then reopen it, and start the share process again.
  3. Click Save and Close to attempt sharing again.

Incorrect files in the company data folder

Create a clean data folder and do an expendable file cleanup. See Create a clean data folder and expendable file cleanup.

Large form files

If the error persists, it can be because of large customized form (.FRM) files. This is evidenced by a delay in making a backup or by apparent "hanging" on certain .FRM files in the backup process. See There’s a delay in backup.

Internet issues

The problem can also be caused by insufficient Internet speed or instability in the Internet connection. See Error: "Failed to contact Remote Data Access server: Sage 50 has lost contact with the current Remote Data Access company."

Firewall

  1. Temporarily Disable the firewall,
  2. Verify that you can successfully upload your company,
  3. If successful, see Files to allow through firewall and antivirus.

Data damage

  • Run Data Verification; see How to run Data Verification
  • You may also try running a Repair Company. refer to How to run a Repair Company
  • DON'T run a Repair Company without first making a backup. That's why we recommend running Data Verification first, as it makes a backup during that process
  • If there are errors during the Repair Company, restore a previous backup from before the data damage occurred
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