Double exclamation marks (!!) appear on the Current Ledger or Year-to-date Ledger in General Ledger (GL current file or history file got recreated due to a missing gateway file)
Description
Cause

The gateway file for the current.glt or history.glt file was missing and the following message was received and OK was clicked (see article 29484 DocLink: Error: "An incomplete [File path] file already exists."):

"An incomplete [file path]\[current.glt or history.glt] file already exists.
To repair the existing file, click [Cancel] and run File Doctor on the file.
If you click [OK], your software will delete the existing file and create a new one. You will lose all transactions in the old file."

Use one or both of the following options to verify. You can also run various transaction based reports and/or inquiries to confirm if all data is missing prior to a certain date or point in time:

Option I: Identify the oldest Date Stamp and Time Stamp in the GL Current file (or GL History file if history is affected)

  1. Use GL, Inquiry, Entries and change the Sort order to batch, entry order.
  2. Add columns for Date Stamp and Time Stamp.
  3. You may want to add a condition for the earliest Date Stamp you see in order to confirm there are no other dates the precede it. (Date Stamp LT [date])
  4. Does the earliest date appear to be the date the file was created (or recreated)?

Option II: Identify the Created date on the data files (MKD files)

Note: You may need assistance from your IT admin to browse to the company data folder path through File Explorer.

WARNING: Use extreme caution when in File Explorer that files are not moved, renamed, deleted, etc.

  1. Using File Explorer, browse to the company data folder.
  2. Open the PVData folder.
  3. Open the current_glt folder (or history_glt folder if the GL history file is affected).
  4. Right-click on the GLT_R1.mkd and select Properties.
  5. Make note of the Created date and time. Is data expected to exist prior to this date and time? (Note: If this file was restored from a backup, the Created date and time will be as of the restore.)

If this is not your issue, refer to article 105554 DocLink: Double exclamation marks (!!) appear on the Current Ledger or Year-to-date Ledger in General Ledger (MASTER ARTICLE) for other possible causes and solutions.

Resolution
[BCB:1:Backup warning:ECB]
IMPORTANT: Start with master article 105554 DocLink: Double exclamation marks (!!) appear on the Current Ledger or Year-to-date Ledger in General Ledger (MASTER ARTICLE) before proceeding with this one.


If the issue from the Cause section above is confirmed, you will need to restore the entire company data folder from backup prior to when the file got recreated.

If you would like to find out if another option is available or if you need help verifying the issue, contact Sage 300 CRE Customer Support for assistance.
DocLink: Double exclamation marks (!!) appear on the Current Ledger or Year-to-date Ledger in General Ledger (MASTER ARTICLE)

[BCB:156:Chat 300 CRE US:ECB]


Steps to duplicate
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